hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Wolf <opus...@gmail.com>
Subject Problem Stopping 0.90.5 Standalone
Date Tue, 10 Jan 2012 17:03:40 GMT
Hello all,

I am having trouble starting and stopping Standalone HBase.

I successfully start Standalone, or at least there is no error message

However, when I try to use the shell, I get this

    hbase(main):001:0> list
    TABLE

    ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException: HBase
    is able to connect to ZooKeeper but the connection closes
    immediately. This could be a sign that the server has too many
    connections (30 is the default). Consider inspecting your ZK server
    logs for that error and then make sure you are reusing
    HBaseConfiguration as often as you can. See HTable's javadoc for
    more information.


And when I try to stop and restart, I get an infinite loop

    Hemiola:~ peter$ dev/hbase-0.90.5/bin/stop-hbase.sh
    stopping
    hbase..................................................................

    Hemiola:~ peter$ dev/hbase-0.90.5/bin/start-hbase.sh
    master running as process 699. Stop it first.

I tried killing the process manually, and I also blew away my hbase 
directory, but it after re-starting the problem is the same.

Can anyone recommend another way to stop, refresh, and restart 
Standalone?  I found this JIRA ticket.  Is this the same issue?  Is 
there a workaround?

    https://issues.apache.org/jira/browse/HBASE-4008


Thanks Peter

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message