hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Stein <charmal...@allthingshadoop.com>
Subject Re: Unresolved Dependencies - 0.90.4
Date Sun, 25 Dec 2011 13:54:28 GMT
ok, figured out what was wrong.

Here are my sbt lines all working for me with a sample client compiling and
working

resolvers += "Apache HBase" at "
https://repository.apache.org/content/repositories/releases"

libraryDependencies ++= Seq(
    "org.apache.hadoop" % "hadoop-core" % "0.20.2",
    "org.apache.hbase" % "hbase" % "0.90.4"
)

thanks

On Sun, Dec 25, 2011 at 8:15 AM, Joe Stein
<charmalloc@allthingshadoop.com>wrote:

> so by adding this repo
>
> http://people.apache.org/~rawson/repo/
>
> I found in the hbase pom I was able to get at thrift 0.2.0 errors to go
> away when updating for the hbase jar for my client code
>
> some new errors now in client
>
> object apache is not a member of package org
> [error] import org.apache.hadoop.hbase.client.HTable
>
> will keep on it
>
> On Sat, Dec 24, 2011 at 7:42 PM, Joe Stein <charmalloc@allthingshadoop.com
> > wrote:
>
>> Hey guys, I am trying to get hbase running in a new sbt Scala client but
>> I am getting all sorts of weird errors with Unresolved Dependencies
>>
>> Specifically -
>>
>> [warn] ::          UNRESOLVED DEPENDENCIES         ::
>> [warn] ::::::::::::::::::::::::::::::::::::::::::::::
>> [warn] :: org.apache.hadoop#hadoop-core;0.20-append-r1056497: not found
>> [warn] :: org.apache.thrift#thrift;0.2.0: not found
>> [warn] ::::::::::::::::::::::::::::::::::::::::::::::
>>
>> error]
>> {file:/Users/joestein/Documents/medialets/SymanticManager/scala/hbasetest/}default-080fe8/*:update:
>> sbt.ResolveException: unresolved dependency:
>> org.apache.hadoop#hadoop-core;0.20-append-r1056497: not found
>> [error] unresolved dependency: org.apache.thrift#thrift;0.2.0: not found
>>
>> seems kind of odd to me (the thrift 0.2.0 error) not sure what maybe I am
>> doing wrong or can be doing differently to get it up and running?
>>
>> I am trying to connect this way in my library dependencies
>>
>> "org.apache.hbase" % "hbase" % "0.90.4" % "test" classifier "tests"
>>
>> any thoughts or assistance to point me in the right direction would be
>> agreat, thanks in advance!!!!
>>
>>
>> /*
>> Joe Stein
>> http://www.linkedin.com/in/charmalloc
>> Twitter: @allthingshadoop <http://twitter.com/#!/allthingshadoop>
>> */
>>
>
>
>
> --
>
> /*
> Joe Stein
> http://www.linkedin.com/in/charmalloc
> Twitter: @allthingshadoop <http://twitter.com/#!/allthingshadoop>
> */
>



-- 

/*
Joe Stein
http://www.linkedin.com/in/charmalloc
Twitter: @allthingshadoop <http://twitter.com/#!/allthingshadoop>
*/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message