hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <jcfol...@pureperfect.com>
Subject RE: What version of HDFS is compatible with HBase?
Date Wed, 21 Dec 2011 21:18:26 GMT



Are you sure your configuration is correct? There's a couple of other
things that you need to do too:


Make sure:


 <property>
    <name>dfs.support.append</name>
    <value>true</value>
  </property>


Is set for both HBase and Hadoop


Update hadoop jars inside the hbase lib directory to use the hadoop
0.20.205 core jar files.


  -------- Original Message --------
 Subject: Re: What version of HDFS is compatible with HBase?
 From: Aleksandr Levchuk <aleksandr@fb.com>
 Date: Wed, December 21, 2011 4:06 pm
 To: <user@hbase.apache.org>
 
 On Hadoop 0.20.205.0 when hbase-0.90.4 master tries to talk to the 
 namenode I get:
 
 logs/hadoop-hadoop-namenode*.log
 2011-12-21 12:57:10,746 WARN org.apache.hadoop.ipc.Server: Incorrect 
 header or version mismatch from 10.30.81.191:33540 got version 3 
 expected version 4
 
 This makes it look like hadoop-0.20.205.0 and hbase-0.90.4 are
incompatible.
 
 Alex
 
 On 12/21/2011 12:41 PM, jcfolsom@pureperfect.com wrote:
 >
 >
 > Use 0.20.205.
 >
 >
 > -------- Original Message --------
 > Subject: What version of HDFS is compatible with HBase?
 > From: Aleksandr Levchuk<aleksandr@fb.com>
 > Date: Wed, December 21, 2011 3:23 pm
 > To:<user@hbase.apache.org>
 >
 > Hi all,
 >
 > HBase stable http://apache.cs.utah.edu/hbase/stable/ is currently
 > hbase-0.90.4, what version(s) of HDFS is it compatible with?
 >
 > There is no answer in the obvious places: Getting Started, README,
 > Changelog, Wiki, FAQ
 > (http://wiki.apache.org/hadoop/Hbase/FAQ_General#A7).
 >
 > http://hbase.apache.org/notsoquick.html has an answer which involves
 > building Hadoop from branch-0.20-append, but I need a release that I
 > can
 > test before building.
 >
 > Thanks,
 > Alex
 >


Mime
View raw message