hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: HRegionserver daemon is not running on one machine.
Date Thu, 17 Nov 2011 22:33:23 GMT
My understanding of your problem is that the folder needs to be
exactly at the same place as on the machine where you're starting
HBase from, even if you set HBASE_HOME to a different to a different
folder on hbase-regionserver1 it's not going to use it.

Hope this helps,

J-D

On Thu, Nov 17, 2011 at 6:34 AM, Vamshi Krishna <vamshi2105@gmail.com> wrote:
> hi
> i am working with 2 node hbase cluster as shown below
> On  node1 (10.0.1.54) : master node, region server, hadoop namenode, hadoop
> datanode
> on node2 (10.0.1.55): region server, hadoop datanode.
> When i start both hadoop then hbase, all daemons are running properly on
> masternode i.e node1,
> 2404 NameNode
> 3657
> 3007 TaskTracker
> 2848 JobTracker
> 3522 HRegionServer
> 3848 Main
> 3292 HQuorumPeer
> 2769 SecondaryNameNode
> 3345 HMaster
> 2575 DataNode
> 4768 Jps
>  but on node2, only TaskTracker and Datanode daemons are running, the
> HRegionServer daemon is not running.
> I provide some files which may be helpful in helping me. i have my
> /etc/hosts file of node1 (vamshikrishna-desktop) has
> # /etc/hosts (for master AND slave)
>
> 127.0.0.1       localhost
> 127.0.1.1       vamshikrishna-desktop
> 10.0.1.54 hbase-master  hadoop-namenode
> 10.0.1.55 hbase-regionserver1   hadoop-datanode1
>
> and file {HBASE_HOME}/conf/regionservers has
>
> hbase-regionserver1
> hbase-master
>
> i have my /etc/hosts file of node2 (vamshikrishna-laptop) has
> 127.0.0.1    localhost
> 127.0.0.1    vamshi-laptop
> 10.0.1.54 hbase-master  hadoop-namenode
> 10.0.1.55 hbase-regionserver1 hadoop-datanode1
>
> and file {HBASE_HOME}/conf/regionservers has
>  localhost
>
> Please can anybody help me in finding out what is the reason for
> Regionserver not running on node2..?  And moreover when i run
> start-hbase.sh , it will display error like
> hbase-regionserver1: bash: line 0: cd: {HBASE_HOME}/bin/..: No such file or
> directory
> hbase-regionserver1: bash: {HBASE_HOME}/bin/hbase-daemon.sh: No such file
> or directory  , but i could find out {HBASE_HOME}/bin/hbase-daemon.sh
> clearly.. i don't know what went wrong..!
>
>
> --
> *Regards*
> *
> Vamshi Krishna
> *
>

Mime
View raw message