hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryce Allen <bal...@ci.uchicago.edu>
Subject Can't get hbase to run using Quickstart
Date Wed, 23 Nov 2011 20:59:37 GMT
I'm trying to get HBase to run in non distributed mode on my
Linux laptop, following quickstart:
http://hbase.apache.org/book/quickstart.html

I can't find a 0.93 snapshot on any mirror, so I've tried compiling
trunk from source and the 0.90.4 binary. In both cases, I get zookeeper
connect errors in the log and eventually the java process dies. I
attached my log file. I'm running Debian sid, and here is my java
version:

java version "1.6.0_23"
OpenJDK Runtime Environment (IcedTea6 1.11pre) (6b23~pre11-1)
OpenJDK Client VM (build 20.0-b11, mixed mode, sharing)

I tried commenting out this in conf/hbase-env.sh:

# Extra Java runtime options.
# Below are what we set by default.  May only work with SUN JVM.
# For more on why as well as other possible settings,
# see http://wiki.apache.org/hadoop/PerformanceTuning
#export HBASE_OPTS="-ea -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode"

and I get the same behavior.

Any ideas? Are there known issues running under OpenJDK?

Thanks,
Bryce

Mime
View raw message