hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: hbase importtsv & completebulkload - permissions error
Date Mon, 12 Sep 2011 23:51:02 GMT
HBase is a bit greedy and expects to own all files it touches. What
would be a better behavior in your opinion for this case?

J-D

On Mon, Sep 12, 2011 at 3:56 PM, Sateesh Lakkarsu <lakkarsu@gmail.com> wrote:
> I used importTsv to create the hfiles, which say end up in:
> - /user/slakkarsu/table/F1 with perms rwxr-xr-x slakkarsu supergroup
>
> time hadoop jar /usr/lib/hbase/hbase-0.90.1-cdh3u0.jar importtsv
> -Dimporttsv.columns=F1:C1,F1:C2,HBASE_ROW_KEY,F1:C4
> -Dimporttsv.bulk.output=/tmp/hbase/bulk_out/tableFoo tableFoo
> /data/tableFoo/part1
>
> Now when I run completebulkload, its failing because of permissions error:
> Caused by: org.apache.hadoop.ipc.RemoteException:
> org.apache.hadoop.security.AccessControlException: Permission denied:
> user=hbase, access=WRITE, inode="F1":slakkarsu:supergroup:rwxr-xr-x
>
> Looks like hbase is trying to move/delete files from F1 folder, but
> obviously doesn't have permissions to do so. I have tried changing ownership
> on F1 manually and that works. Is this supposed to work without manual step?
> am I doing something wrong?
>
> Thanks.
>

Mime
View raw message