hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Cuthbert <bencuthb...@ymail.com>
Subject Re: hbase.tmp dir property not working
Date Sun, 28 Aug 2011 21:15:19 GMT
My hbase config looks like this. I thought with the configuration below i would be connecting
to hadoop and using that rather than a local store.

<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="configuration.xsl"?>
<configuration>

	<!-- Celertech hbase configuraiton. Further details can be found at http://hbase.apache.org/docs/r0.20.6/hbase-conf.html
-->
	<property>
		<name>hbase.rootdir</name>
		<value>hdfs://localhost:50009/hbase</value>
		<description>The directory shared by RegionServers.
		</description>
	</property>

	<property>
		<name>hbase.tmp.dir</name>
		<value>/Users/ben//hbase</value>
		<description>The directory shared by RegionServers.
		</description>
	</property>
	
	<property>
		<name>hbase.client.scanner.caching</name>
		<value>100</value>
		<description>
  		 Number of rows that will be fetched when calling next on a scanner if it is not served
from memory. 
		 Higher caching values will enable faster scanners but will eat up more memory and some
calls of next may take longer and longer times when the cache is empty.
		</description>
	</property>

	<property>
		<name>hbase.cluster.distributed</name>
		<value>false</value>
		<description>The mode the cluster will be in. Possible values are
			false: standalone and pseudo-distributed setups with managed
			Zookeeper
			true: fully-distributed with unmanaged Zookeeper Quorum (see
			hbase-env.sh)
		</description>
	</property>
	
	<!-- Hbase master info -->
	<property>
		<name>hbase.master.port</name>
		<value>60000</value>
		<description>The port master should bind to.
		</description>
	</property>

	<property>
		<name>hbase.master.info.port</name>
		<value>60010</value>
		<description>The port for the hbase master web UI Set to -1 if you do not want the
info server to run.
		</description>
	</property>
	
	<property>
		<name>hbase.master.info.bindAddress</name>
		<value>localhost</value>
		<description>The address for the hbase master web UI.
		</description>
	</property>


	<!-- Zoo keeper configurations -->
	<property>
		<name>zookeeper.znode.rootserver</name>
		<value>root-region-server</value>
		<description>Path to ZNode holding root region location.
			This is written by the master and read by clients and region servers.
			If a relative path is given, the parent folder will be
			${zookeeper.znode.parent}.
			By default, this means the root location is stored at
			/hbase/root-region-server.
		</description>
	</property>

	<property>
		<name>zookeeper.session.timeout</name>
		<value>2000</value>
		<description>Default timeout for connecting to zookeeper
		</description>
	</property>


	<property>
		<name>hbase.zookeeper.quorum</name>
		<value>localhost</value>
	</property>
	
	<property>
		<name>zookeeper.session.timeout</name>
		<value>60000</value>
	</property>
	<property>
		<name>hbase.zookeeper.property.dataDir</name>
		<value>/Users/ben/hbase/zookeeper</value>
	</property>
	<property>
		<name>hbase.zookeeper.property.maxClientCnxns</name>
		<value>100</value>
	</property>

</configuration>

On 28 Aug 2011, at 22:08, lars hofhansl wrote:

> Hi Ben,
> 
> Are you running HBase in local mode? Did you also set hbase.rootdir?
> hbase.rootdir defaults to file:///tmp/hbase-${user.name}/hbase.
> 
> 
> -- Lars
> ________________________________
> From: Ben Cuthbert <bencuthbert@ymail.com>
> To: user@hbase.apache.org
> Sent: Sunday, August 28, 2011 12:01 PM
> Subject: hbase.tmp dir property not working
> 
> Any have any issues with the following property not working.
> 
> 
>     <property>
>         <name>hbase.tmp.dir</name>
>         <value>/Users/ben//hbase</value>
>         <description>The directory shared by RegionServers.
>         </description>
>     </property>
> 
> 
> When I set this, hbase still creates it's filesystem in /tmp/hbase-ben


Mime
View raw message