hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Upgrade from 0.90.1 to 0.90.2/3
Date Thu, 04 Aug 2011 18:36:41 GMT
All minor versions are compatible between them, you can do a rolling
upgrade if you want:
http://hbase.apache.org/book/decommission.html#rolling

All you need to add is a step where you replace the distribution
before restarting the process.

J-D

On Thu, Aug 4, 2011 at 11:29 AM, Weiwei Xiong <xiongww@gmail.com> wrote:
> Hi all,
>
> I am currently using hbase 0.90.1 but got an issue same as HBASE-3660. It
> seems this problem has been solved in 0.90.2. So I want to upgrade to it.
>
> The question is, can I safely upgrade to 0.90.2/3 from 0.90.1 by replacing
> the whole HBASE package with the newer one? I am really concerned if it
> might break the metadata and I can't even go back to 0.90.1 once I tried.
>
> Thanks,
> -- ww
>

Mime
View raw message