hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florin P <florinp...@yahoo.com>
Subject Re: zookeeper connection issue - distributed mode
Date Tue, 05 Jul 2011 14:00:05 GMT
Hello!

The property hbase.zookeeper.quorum is taken from hbase-site.xml on 

the HBase master machine. 
   taken from Hbase master hbase-site.xml
		<property>
		 <name>hbase.zookeeper.quorum</name>
		<value><your_server_name></value>
		</property>

For me, it worked.
  Success,
 Florin

--- On Tue, 7/5/11, devush <devushanker@gmail.com> wrote:

> From: devush <devushanker@gmail.com>
> Subject: zookeeper connection issue - distributed mode
> To: user@hbase.apache.org
> Date: Tuesday, July 5, 2011, 5:44 AM
> Hi,
> 
> i have following environment - hbase-0.90.1-cdh3u0 on
> ubuntu.
> 
> I have following code for the distributed mode and i am
> calling this
> java code from remote client:
>                
>         HBaseConfiguration config = new
> HBaseConfiguration();
>                
>         config.clear();
>            
> config.set("hbase.zookeeper.quorum", "ults01");
>            
> config.set("hbase.zookeeper.property.clientPort", "2181");
> 
> and I get following log:
> 11/07/05 03:33:03 INFO zookeeper.ZooKeeper: Client
> environment:zookeeper.version=3.3.2-1031432, built on
> 11/05/2010 05:32
> GMT
> 11/07/05 03:33:03 INFO zookeeper.ZooKeeper: Client
> environment:host.name=192.168.1.64
> ...
> 11/07/05 03:21:32 INFO zookeeper.ZooKeeper: Initiating
> client
> connection, connectString=ults01:2181
> sessionTimeout=180000
> watcher=hconnection
> 11/07/05 03:21:32 INFO zookeeper.ClientCnxn: Opening socket
> connection
> to server ults01/192.168.22.133:2181
> 11/07/05 03:21:32 INFO zookeeper.ClientCnxn: Socket
> connection
> established to ults01/192.168.22.133:2181, initiating
> session
> 11/07/05 03:21:32 INFO zookeeper.ClientCnxn: Session
> establishment
> complete on server ults01/192.168.22.133:2181, sessionid =
> 0x130f352453f0027, negotiated timeout = 40000
> 11/07/05 03:21:32 INFO ipc.HbaseRPC: Server at
> localhost/127.0.0.1:60020 could not be reached after 1
> tries, giving
> up.
> 11/07/05 03:21:33 INFO ipc.HbaseRPC: Server at
> localhost/127.0.0.1:60020 could not be reached after 1
> tries, giving
> up.
> 11/07/05 03:21:34 INFO ipc.HbaseRPC: Server at
> localhost/127.0.0.1:60020 could not be reached after 1
> tries, giving
> up.
> 11/07/05 03:21:35 INFO ipc.HbaseRPC: Server at
> localhost/127.0.0.1:60020 could not be reached after 1
> tries, giving
> up.
> 
> my conf/regionservers used to have the localhost entry,
> which i tried
> to change to the hostname ults01, but no luck.
> 
> /etc/hosts:
> 127.0.0.1    localhost
> #127.0.0.1    ults01
> 192.168.22.133     ults01
> 
> Basic question is from where it is picking up
> localhost/127.0.0.1:60020?
> I think, it should be ults01/192.168.22.133:60020.
> Even worst, it use to work, but due to the virtual server
> move, i have
> to change the IP address of ults01 machine.
> 
> thanks for comments.
> regards,
> devush
> 

Mime
View raw message