hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dhruba Borthakur <dhr...@gmail.com>
Subject Re: Does anybody enable MSLAB in production system? I am not sure if it's stable enough for production system?
Date Sun, 26 Jun 2011 00:59:02 GMT
I have been using it too, and it does reduce GC to a large extent! Going
forward, it might make sense to enable this option by default.

thanks,
dhruba

On Sat, Jun 25, 2011 at 4:30 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:

> The only thing we saw is that with a high enough count of regions
> (close to a thousand and more) the cost of each memstore (2MB by
> default even when empty, and that's per family per region) is enough
> to put you at a higher risk of getting OOMEs if you don't modify your
> heap after enabling mslab. I would recommend enabling it on a few
> region servers to see how it goes if you aren't sure.
>
> J-D
>
> On Sat, Jun 25, 2011 at 11:20 AM, Andrew Purtell <apurtell@apache.org>
> wrote:
> >>From: Jack Zhang(jian) <jack.zhangjian@huawei.com>
> >
> >>Subject: Does anybody enable MSLAB in production system? I am not sure if
> it's stable enough for production system?
> >
> >
> > Yes, we use it in production and have not observed any negative effects
> of its use.
> >
> > Best regards,
> >
> >
> >   - Andy
> >
> > Problems worthy of attack prove their worth by hitting back. - Piet Hein
> (via Tom White)
> >
>



-- 
Connect to me at http://www.facebook.com/dhruba

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message