hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Tests fail while building 0.90.3
Date Wed, 22 Jun 2011 23:59:46 GMT
I checked both 0.90 branch and trunk - indeed, testWritesWhileScanning is
used as tablename for testWritesWhileGetting

Do you mind filing a JIRA ?

BTW there seems to be some issue with your patch/diff - it seems to show
your change in the other direction. I can help you generate a correct patch.

Thanks Vandana.

On Wed, Jun 22, 2011 at 4:06 PM, Vandana Ayyalasomayajula <
avandana@yahoo-inc.com> wrote:

> Thanks Ted for suggesting to use eclipse and debug the tests. It helped a
> lot.
>
> So the issue is with the "testWritesWhileGetting" unit test in the
> org.apache.hadoop.hbase.regionserver.TestHRegion test.  In the unit test,
>  "initHRegion" method is used to initialize a new HRegion.This method tries
> to create a new HRegion, if one does not exist else deletes an
> existing one and creates it again. In my case, the deletion was not
> happening as the log files related to the previously created HRegion
> were still in use and hence the IO exeception.
>
> I looked into a little deeper to find that "initHRegion" method takes
> inputs as table name, calling method name and names of column families.
> In this unit test, both the table name and the calling method name were
> "testWritesWhileScanning". I changed the calling method name to be
> "testWritesWhileGetting" and all my unit tests pass.
>
> So I am suspecting this was a small error in the test, which needs to be
> fixed. Please let me know if this is not the case.
>
> Thanks
> Vandana
>
>
>
> On Jun 19, 2011, at 2:56 PM, Ted Yu wrote:
>
> > If TestHRegion-output.txt doesn't give us much clue, you can debug the
> test
> > in Eclipse, e.g.
> > The following command would generate .project file:
> > mvn eclipse:eclipse
> >
> > On Fri, Jun 17, 2011 at 9:01 AM, Vandana Ayyalasomayajula <
> > avandana@yahoo-inc.com> wrote:
> >
> >> The file is not there on my computer. So is there something I am missing
> to
> >> do before the build process ?
> >>
> >>
> >> On Jun 17, 2011, at 2:11 AM, Ted Yu wrote:
> >>
> >>> I was hoping to see more clue as to why
> >>>
> >>
> /homes/avandana/hbase/hbase-0.90.3/build/hbase/test/TestHRegion/testWritesWhileScanning
> >>> couldn't be deleted.
> >>>
> >>> Did you verify whether the file was on your computer ?
> >>>
> >>> BTW I looked at the output.txt on my laptop. The log about HDFS-826 and
> >>> HDFS-200 was there - but the test passed.
> >>> Cheers
> >>> On Fri, Jun 17, 2011 at 1:50 PM, Vandana Ayyalasomayajula <
> >>> avandana@yahoo-inc.com> wrote:
> >>>
> >>>> The contents of
> >> TEST-org.apache.hadoop.hbase.regionserver.TestHRegion.xml
> >>>> is available at:
> >>>> http://pastebin.com/myGhd273
> >>>>
> >>>> The error can be found here. I think that is causing the exception.
> >>>>
> >>>> Thanks
> >>>> Vandana
> >>>> On Jun 16, 2011, at 5:54 PM, Ted Yu wrote:
> >>>>
> >>>>> IOException didn't appear in output.txt
> >>>>> Please give stack trace for the exception.
> >>>>>
> >>>>> I noticed the following in the output:
> >>>>>
> >>>>> 2011-06-16 16:23:19,585 INFO  [main] wal.HLog(396):
> >>>>> getNumCurrentReplicas--HDFS-826 not available;
> >>>>>
> >>>>
> >>
> hdfs_out=org.apache.hadoop.fs.ChecksumFileSystem$ChecksumFSOutputSummer@6ec5122f
> >>>> ,
> >>>>>
> >>>>
> >>
> exception=org.apache.hadoop.fs.ChecksumFileSystem$ChecksumFSOutputSummer.getNumCurrentReplicas()
> >>>>>
> >>>>> On Fri, Jun 17, 2011 at 7:30 AM, Vandana Ayyalasomayajula <
> >>>>> avandana@yahoo-inc.com> wrote:
> >>>>>
> >>>>>> Hi,
> >>>>>>
> >>>>>> I am running the build on rhel 5 machine. I ran the following
> command:
> >>>>>>
> >>>>>> mvn clean test -Dtest=TestHRegion
> >>>>>>
> >>>>>> and the contents of TestHRegion-output.txt are in:
> >>>>>>
> >>>>>> http://pastebin.com/0WZkapGD
> >>>>>>
> >>>>>> Thanks
> >>>>>> Vandana
> >>>>>>
> >>>>>> On Jun 16, 2011, at 4:03 PM, Stack wrote:
> >>>>>>
> >>>>>>> What Ted said and what happens if you run it standalone?
> >>>>>>>
> >>>>>>> mvn clean test -Dtest=TestHRegion
> >>>>>>>
> >>>>>>> St.Ack
> >>>>>>>
> >>>>>>> On Thu, Jun 16, 2011 at 4:01 PM, Ted Yu <yuzhihong@gmail.com>
> wrote:
> >>>>>>>> Can you tell us about your OS ?
> >>>>>>>> Also, can you put TestHRegion-output.txt on pastebin
?
> >>>>>>>> Thanks
> >>>>>>>> On Fri, Jun 17, 2011 at 6:57 AM, Vandana Ayyalasomayajula
<
> >>>>>>>> avandana@yahoo-inc.com> wrote:
> >>>>>>>>
> >>>>>>>>> Hi All,
> >>>>>>>>>
> >>>>>>>>> I am trying to build HBase-0.90.3 on my machine.
I am using
> Hadoop
> >>>> 0.20
> >>>>>>>>> append version described in the page:
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>
> >>>>
> >>
> http://www.michael-noll.com/blog/2011/04/14/building-an-hadoop-0-20-x-version-for-hbase-0-90-2/
> >>>>>>>>>
> >>>>>>>>> The test "org.apache.hadoop.hbase.regionserver.TestHRegion"
with
> >> the
> >>>>>>>>> following exception:
> >>>>>>>>>
> >>>>>>>>> java.io.IOException: Failed delete of
> >>>>>>>>>
> >>>>>>
> >>>>
> >>
> /home/temp/hbase-0.90.3/build/hbase/test/TestHRegion/testWritesWhileScanning
> >>>>>>>>>
> >>>>>>>>> Any help would be greatly appreciated.
> >>>>>>>>>
> >>>>>>>>> Thanks
> >>>>>>>>> Vandana
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>
> >>>>>>
> >>>>>> Vandana Ayyalasomayajula
> >>>>>> avandana@yahoo-inc.com
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>
> >>>> Vandana Ayyalasomayajula
> >>>> avandana@yahoo-inc.com
> >>>>
> >>>>
> >>>>
> >>
> >> Vandana Ayyalasomayajula
> >> avandana@yahoo-inc.com
> >>
> >>
> >>
>
> Vandana Ayyalasomayajula
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message