hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joey Echeverria <j...@cloudera.com>
Subject Re: Hadoop Version
Date Thu, 23 Jun 2011 16:13:13 GMT
Andy,

That's a typical solution. The key is that the hadoop-core jar in you
HDFS install has to match the hadoop-core jar in HBase's lib
directory. The -append version that ships with HBase is needed to
prevent data loss.

-Joey

On Thu, Jun 23, 2011 at 11:54 AM, Zhong, Andy <Sheng.Zhong@searshc.com> wrote:
> We have tried Hbase Upgrade from 0.20.3 to 0.90.2 on Hadoop 0.20.2 for a
> real time app, but had to replace hadoop-core with
> hadoop-core-0.20-append-r1056497.jar shipped from Hbase 0.90.2 otherwise
> Hbase won't start as compatible issue. This is based on Michael Noll's
> suggestion, but not sure if it's a valid option, anyone else tried that,
> and will propose any other issue?
>
> Thanks,
> Andy Z.
>
> -----Original Message-----
> From: Joey Echeverria [mailto:joey@cloudera.com]
> Sent: Thursday, June 23, 2011 7:59 AM
> To: user@hbase.apache.org
> Subject: Re: Hadoop Version
>
> It will "work", however, hadoop-.20-203 doesn't have append support so
> there is the risk of data loss.
>
> See http://hbase.apache.org/book/hadoop.html for more details on Hadoop
> versions.
>
> -Joey
>
> On Thu, Jun 23, 2011 at 6:32 AM, Saumitra Chowdhury
> <saumitra@smartitengineering.com> wrote:
>> Dear all,
>>
>> We are using Hbase 90.2 with hadoop-0.20. Will it be any problem if we
>
>> upgrade to hadoop-0.20.203 in real time server?
>> In fact I wanna know that have anyone tested it with hbase 90.x
>> series? I have heard some problem about hadoop-0.21 but heard nothing
>> about this version.
>>
>> BR
>> Saumitra Chowdhury
>>
>
>
>
> --
> Joseph Echeverria
> Cloudera, Inc.
> 443.305.9434
>



-- 
Joseph Echeverria
Cloudera, Inc.
443.305.9434

Mime
View raw message