hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From praveenesh kumar <praveen...@gmail.com>
Subject Re: Hadoop not working after replacing hadoop-core.jar with hadoop-core-append.jar
Date Mon, 06 Jun 2011 13:23:48 GMT
Hello guys..

Changing the name of the hadoop-apppend-core.jar file to
hadoop-0.20.2-core.jar did the trick..
Its working now..
But is this the right solution to this problem ??

Thanks,
Praveenesh

On Mon, Jun 6, 2011 at 2:18 PM, praveenesh kumar <praveenesh@gmail.com>wrote:

>
> Hi,
>
> Not able to see my email in the mail archive..So sending it again...!!!
> Guys.. need your feedback..!!
>
> Thanks,
> Praveenesh
> ---------- Forwarded message ----------
> From: praveenesh kumar <praveenesh@gmail.com>
> Date: Mon, Jun 6, 2011 at 12:09 PM
> Subject: Hadoop is not working after adding
> hadoop-core-0.20-append-r1056497.jar
> To: common-user@hadoop.apache.org, user@hbase.apache.org
>
>
> Hello guys..!!!
>
> I am currently working on Hbase 0.90.3 and Hadoop 0.20.2
>
> Since this hadoop version does not support rsync hdfs..
> so I copied the *hadoop-core-append jar*  file from *hbase/lib* folder
> into* hadoop folder* and replaced it with* hadoop-0.20.2-core.jar*
> which was suggested in the following link
>
>
> http://www.apacheserver.net/Using-Hadoop-bundled-in-lib-directory-HBase-at1136240.htm
>
> I guess this is what have been mentioned in the link that I am doing. If I
> am doing somehting wrong, kindly tell me.
>
> But now after adding that jar file.. I am not able to run my hadoop.. I am
> getting following exception messages on my screen
>
> ub13: Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/hadoop/util/PlatformName
> ub13: Caused by: java.lang.ClassNotFoundException:
> org.apache.hadoop.util.PlatformName
> ub13:   at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
> ub13:   at java.security.AccessController.doPrivileged(Native Method)
> ub13:   at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
> ub13:   at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
> ub13:   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
> ub13:   at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
> ub13: Could not find the main class: org.apache.hadoop.util.PlatformName.
> Program will exit.
> ub13: Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/hadoop/hdfs/server/datanode/DataNode
> ub13: starting secondarynamenode, logging to
> /usr/local/hadoop/hadoop/bin/../logs/hadoop-hadoop-secondarynamenode-ub13.out
> ub13: Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/hadoop/util/PlatformName
> ub13: Caused by: java.lang.ClassNotFoundException:
> org.apache.hadoop.util.PlatformName
> ub13:   at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
> ub13:   at java.security.AccessController.doPrivileged(Native Method)
> ub13:   at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
> ub13:   at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
> ub13:   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
> ub13:   at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
> ub13: Could not find the main class: org.apache.hadoop.util.PlatformName.
> Program will exit.
> ub13: Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/hadoop/hdfs/server/namenode/SecondaryNameNode
> Have I done something wrong.. Please guide me...!!
>
> Thanks,
> Praveenesh
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message