hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vandana Ayyalasomayajula <avand...@yahoo-inc.com>
Subject Re: Tests fail while building 0.90.3
Date Fri, 17 Jun 2011 05:50:04 GMT
The contents of  TEST-org.apache.hadoop.hbase.regionserver.TestHRegion.xml is available at:
http://pastebin.com/myGhd273

The error can be found here. I think that is causing the exception.

Thanks
Vandana
On Jun 16, 2011, at 5:54 PM, Ted Yu wrote:

> IOException didn't appear in output.txt
> Please give stack trace for the exception.
> 
> I noticed the following in the output:
> 
> 2011-06-16 16:23:19,585 INFO  [main] wal.HLog(396):
> getNumCurrentReplicas--HDFS-826 not available;
> hdfs_out=org.apache.hadoop.fs.ChecksumFileSystem$ChecksumFSOutputSummer@6ec5122f,
> exception=org.apache.hadoop.fs.ChecksumFileSystem$ChecksumFSOutputSummer.getNumCurrentReplicas()
> 
> On Fri, Jun 17, 2011 at 7:30 AM, Vandana Ayyalasomayajula <
> avandana@yahoo-inc.com> wrote:
> 
>> Hi,
>> 
>> I am running the build on rhel 5 machine. I ran the following command:
>> 
>> mvn clean test -Dtest=TestHRegion
>> 
>> and the contents of TestHRegion-output.txt are in:
>> 
>> http://pastebin.com/0WZkapGD
>> 
>> Thanks
>> Vandana
>> 
>> On Jun 16, 2011, at 4:03 PM, Stack wrote:
>> 
>>> What Ted said and what happens if you run it standalone?
>>> 
>>> mvn clean test -Dtest=TestHRegion
>>> 
>>> St.Ack
>>> 
>>> On Thu, Jun 16, 2011 at 4:01 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>>>> Can you tell us about your OS ?
>>>> Also, can you put TestHRegion-output.txt on pastebin ?
>>>> Thanks
>>>> On Fri, Jun 17, 2011 at 6:57 AM, Vandana Ayyalasomayajula <
>>>> avandana@yahoo-inc.com> wrote:
>>>> 
>>>>> Hi All,
>>>>> 
>>>>> I am trying to build HBase-0.90.3 on my machine. I am using Hadoop 0.20
>>>>> append version described in the page:
>>>>> 
>>>>> 
>>>>> 
>> http://www.michael-noll.com/blog/2011/04/14/building-an-hadoop-0-20-x-version-for-hbase-0-90-2/
>>>>> 
>>>>> The test "org.apache.hadoop.hbase.regionserver.TestHRegion" with the
>>>>> following exception:
>>>>> 
>>>>> java.io.IOException: Failed delete of
>>>>> 
>> /home/temp/hbase-0.90.3/build/hbase/test/TestHRegion/testWritesWhileScanning
>>>>> 
>>>>> Any help would be greatly appreciated.
>>>>> 
>>>>> Thanks
>>>>> Vandana
>>>>> 
>>>>> 
>>>>> 
>>>> 
>> 
>> Vandana Ayyalasomayajula
>> avandana@yahoo-inc.com
>> 
>> 
>> 

Vandana Ayyalasomayajula
avandana@yahoo-inc.com



Mime
View raw message