hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Graham <billgra...@gmail.com>
Subject Re: IO Error when using multiple HBaseStorage in PIG
Date Fri, 20 May 2011 21:29:31 GMT
Yes, that's what it seems. I've opened a Pig JIRA for it:

https://issues.apache.org/jira/browse/PIG-2085

On Thu, May 19, 2011 at 1:31 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:

> Your attachement didn't make it, it rarely does on the mailing lists.
> I suggest you use a gist.github or a pastebin.
>
> Regarding the error, looks like something closed the HCM and someone
> else is trying to use it. Since this is client side, it would point to
> a Pig problem.
>
> J-D
>
> On Thu, May 19, 2011 at 12:28 PM, Keric Donnelly
> <keric.donnelly@cbsinteractive.com> wrote:
> > To All,
> > I'm running into IO issues when trying to write to an Hbase table using
> > multiple STORE commands in PIG script. I can comment out any 2 of the
> STORE
> > statements and run the script and then the data inserts fine. If I try
> and
> > run with all 3  get the following:
> > java.io.IOException:
> >
> org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation@26c1186f
> > closed
> >
> > I've attached a simplified version of the script to illustrate the
> problem.
> >
> > Any thoughts or comments are appreciated.
> >
> > Thanks
> >
> > Keric
> >
> >
> > --
> >
> > Keric Donnelly
> > Senior Data Architect
> > T 954-689-3291   C 954.683.5445
> >
> > 1401 West Cypress Creek Road, Fort Lauderdale, FL 33309
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message