hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bijieshan <bijies...@huawei.com>
Subject Re: Regions count is not consistant between the WEBUI and LoaderBalancer
Date Wed, 18 May 2011 02:00:30 GMT
Yes, you're right. While count the .META., the result will exclude the -ROOT- region and the
.META. region. Pardon me ,I should not mention about that.
Maybe the less 2 region is just a coincidence here, I can show another scenario about this
problem:

From WebUI, we can see that:

Address Start Code Load 
C4C3.site:60030 1305620850621 requests=0, regions=10227, usedHeap=2161, maxHeap=8175 
C4C4.site:60030 1305620851291 requests=0, regions=10234, usedHeap=2593, maxHeap=8175 
C4C5.site:60030 1305620851505 requests=0, regions=10227, usedHeap=2191, maxHeap=8175 
Total:  servers: 3   requests=0, regions=30688

From HMaster logs:

2011-05-18 10:06:08,382 INFO org.apache.hadoop.hbase.master.LoadBalancer: Skipping load balancing.
 servers=3 regions=30681 average=10227.0 mostloaded=10227 leastloaded=10227
2011-05-18 10:06:13,365 DEBUG org.apache.hadoop.hbase.zookeeper.ZKUtil: hconnection opening
connection to ZooKeeper with ensemble (C4C3:2181,C4C2:2181,C4C1:2181)


30681 & 30688

7 region differ from this  scenario.

Thanks!

Regards,
Jieshan Bean


-----邮件原件-----
发件人: cft@tarnas.org [mailto:cft@tarnas.org] 代表 Christopher Tarnas
发送时间: 2011年5月17日 22:40
收件人: user@hbase.apache.org
主题: Re: Regions count is not consistant between the WEBUI and LoaderBalancer

.META. does not include region information for itself or -ROOT- so a count
of .META. should always be two regions less than the total number.

-chris

On Tue, May 17, 2011 at 4:32 AM, bijieshan <bijieshan@huawei.com> wrote:

> This problem seems happened with high probability, I have saw it several
> times.
>
> Here's the description about this problem:
>
> 1.From the WEBUI, I can see the regions count is:35087.
> 2.From the HBase shell, I counted the '.META.' table, and it showed there's
> 35085 regions.
>
> hbase(main):001:0> count '.META.',10000
> 11/05/14 14:12:22 INFO jute.BinaryInputArchive: Expecting maxBufferString
> as an integer but got as null.Hence setting to default value 1048575
> Current count: 10000, row:
> hello,080472,1305272720373.ec0eb8c1bb414967241155cf0985241e.
> Current count: 20000, row:
> hello,161272,1305272956858.e16008645368590dfa735abc61024db6.
> Current count: 30000, row:
> ufdr,061870,1305171874909.eddc77cbfa2f93feef49f4485d9b88a5.
> 35085 row(s) in 2.5250 seconds
>
> 3.From the HMaster logs, I saw that:
>
> 2011-05-14 14:13:57,546 INFO org.apache.zookeeper.ClientCnxn: EventThread
> shut down
> 2011-05-14 14:14:01,303 INFO org.apache.hadoop.hbase.master.LoadBalancer:
> Skipping load balancing.  servers=4 regions=35089 average=8772.25
> mostloaded=8773 leastloaded=8773
> 2011-05-14 14:14:08,706 DEBUG
> org.apache.hadoop.hbase.master.CatalogJanitor: Scanned 35085 catalog row(s)
> and gc'd 0 unreferenced parent region(s)
>
> 35087 & 35085 , so where's the problem? Were they from the different sets?
>
> Thanks!
>
> Regards,
> Jieshan Bean
>
>
>
>
Mime
View raw message