hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Hbase 0.90.2 problems
Date Sat, 09 Apr 2011 16:22:55 GMT
Looks like your zookeeper isn't running for some reason, that's
usually what "connection refused" means. Also notice it connects on
localhost.

J-D

On Fri, Apr 8, 2011 at 11:54 PM, William Kang <weliam.cloud@gmail.com> wrote:
> Hi folks,
> I recently upgraded to hbase 0.90.2 that runs with hadoop 0.20.1. And
> I got the following errors in the hbase logs:
>
> 2011-04-09 02:28:02,429 INFO org.apache.zookeeper.ClientCnxn: Opening
> socket connection to server localhost/127.0.0.1:2181
> 2011-04-09 02:28:02,430 WARN org.apache.zookeeper.ClientCnxn: Session
> 0x12f...... for server null, unexpected error, closing socket
> connection and attempting reconnect
> java.net.ConnectException: Connection refused
>        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>        at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
>        at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1119)
>
> Hadoop is running ok. I did not have this problem with hbase 0.2x
> before. I guess I must have missed something here.
> I am running this in pseudo mode. With mostly default conf. Only
> changes is to set Java_home and hadoop dfs address. The OS is untuntu
> 10.10.
> What might have caused this problem? Thanks a lot.
>
>
> William
>

Mime
View raw message