hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: hbase 0.90.2 - incredibly slow response
Date Wed, 20 Apr 2011 18:11:00 GMT
Want to paste your configuration up in pastebin?

Is that 700million puts a day?

Remind us of your cluster size.

Paste some of a regionserver log too.  That can be informative.

St.Ack

On Wed, Apr 20, 2011 at 10:41 AM, Venkatesh <vramanathan00@aol.com> wrote:
> shell is no problems..ones/twos..i've tried mass puts from shell
> we cant handle our production load (even 1/3 of it)
> 700 mill per day is full load..same load we handled with absolutely no issues in 0.20.6..
> there is several pause between batch of puts as wel
>
>
>
>
>
>
>
>
>
>
> -----Original Message-----
> From: Stack <stack@duboce.net>
> To: user@hbase.apache.org
> Sent: Wed, Apr 20, 2011 1:30 pm
> Subject: Re: hbase 0.90.2 - incredibly slow response
>
>
> On Tue, Apr 19, 2011 at 11:58 AM, Venkatesh <vramanathan00@aol.com> wrote:
>
>>
>
>>  I was hoping that too..
>
>> I don't have scripts to generate # requests from shell..I will try that..
>
>>
>
>
>
> Did you try it?
>
>
>
> Above you seem to say that a simple put of < 100 bytes takes 2 seconds
>
> where in 0.20.6 it took < 10 milliseconds.  A put from shell of 100
>
> bytes is easy enough to do.
>
>
>
> hbase> put 'YOUR_TABLE', 'SOME_ROW', 'SOME_COLUMN', 'SOME_STRING_OF_100_BYTES'
>
>
>
> The shell will print out rough numbers on how long it takes to do the
>
> put (from ruby).
>
>
>
>
>
>> I did n't pre-create regions in 0.20.6 & it handled fine the same load..
>
>> I'll try performance in 0.90.2 by precreating regions..
>
>>
>
>> Would sharing a single HBaseConfiguration object for all threads hurt
>
> performance?
>
>>
>
>
>
> I'd doubt that this is the issue.  It should help usually.
>
>
>
> St.Ack
>
>
>
>

Mime
View raw message