hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: HBase 0.90.2 CDH3B4 -Compression algorithm 'lzo' previously failed test
Date Tue, 19 Apr 2011 05:47:25 GMT
It looks like its still not installed correctly; HBase when it runs
can't find it (You restarted between installs?  What does the
CompressionTool say when you run it?  See
http://hbase.apache.org/book.html#compression The same thing?)  Where
did you put the native libs?

St.Ack



On Mon, Apr 18, 2011 at 10:41 PM, Vadim Keylis <vkeylis2009@gmail.com> wrote:
> Good evening. I've read the article(
> https://github.com/toddlipcon/hadoop-lzo) and configured the way it
> describes, but I still get the same error.
>
> 2011-04-18 15:09:11,635 ERROR
> org.apache.hadoop.hbase.regionserver.handler.OpenRegionHandler: Failed open
> of
> region=user,10L\xA2\x13\xDB\xDB\xDB\xDB\xDA\xDA\xB0\x05Z\xCCw!\xCC\x93\xB0!\xCC\x93\x93\xB0!\xCCw!\xCCw!\xCCw
> ,1303164462772.dbbb665cfc461075670f06f4dfe6b632.
>
> java.io.IOException: Compression algorithm 'lzo' previously failed test.
>         at
> org.apache.hadoop.hbase.util.CompressionTest.testCompression(CompressionTest.java:77)
>         at
> org.apache.hadoop.hbase.regionserver.HRegion.checkCompressionCodecs(HRegion.java:2555)
>         at
> org.apache.hadoop.hbase.regionserver.HRegion.openHRegion(HRegion.java:2544)
>         at
> org.apache.hadoop.hbase.regionserver.HRegion.openHRegion(HRegion.java:2532)
>         at
> org.apache.hadoop.hbase.regionserver.handler.OpenRegionHandler.openRegion(OpenRegionHandler.java:262)
>         at
> org.apache.hadoop.hbase.regionserver.handler.OpenRegionHandler.process(OpenRegionHandler.java:94)
>         at
> org.apache.hadoop.hbase.executor.EventHandler.run(EventHandler.java:151)
>         at
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>         at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>         at java.lang.Thread.run(Thread.java:619)
>
>
> I check out hadoop-lzo from the link you provided and rebuild the library
> based on the instruction in FAQ.
>
> Here my configuration:
>
> hadoop-env.sh:
>
>    export
> JAVA_LIBRARY_PATH="/home/hbase/hadoop-lzo-0.4.10/lib/native/Linux-amd64-64/"
>    # Extra Java CLASSPATH elements.  Optional.
>    export
> HADOOP_CLASSPATH="/home/hbase/hadoop-lzo-0.4.10/hadoop-lzo-0.4.10.jar"
>
>
> core-site.xml
>
>   <property>
>     <name>io.compression.codecs</name>
>
> <value>org.apache.hadoop.io.compress.GzipCodec,org.apache.hadoop.io.compress.DefaultCodec,com.hadoop.compression.lzo.LzoCodec,com.hadoop.compression.lzo.LzopCodec,org.apache.hadoop.io.compress.BZip2Codec</value>
>   </property>
>   <property>
>     <name>io.compression.codec.lzo.class</name>
>     <value>com.hadoop.compression.lzo.LzoCodec</value>
>   </property>
>
> hbase-env.sh:
>
> export HBASE_CLASSPATH="/home/hbase/
> hadoop-lzo-0.4.10/hadoop-lzo-0.4.10.jar:$HBASE_CLASSPATH"
>
> What am I doing wrong
>
>

Mime
View raw message