hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harold Lim <rold...@yahoo.com>
Subject Re: Write Operations on a Table Hangs
Date Thu, 28 Apr 2011 21:59:30 GMT
Hi J-D,

What I notice is that, when a region server is going to split the region (create more regions),
the write operations kind of paused, and then after a few seconds, the write operations of
my program will continue. 

However, there are cases where the write operations does not work anymore. I go to the hbase
shell and try to do some operations on the table and it does not work too.  Operations on
other table still seem to work fine.


I'm using HBase 0.20.x (manually compiled). It's a 10 node cluster on EC2. No special configurations.


Thanks,
Harold



--- On Thu, 4/28/11, Jean-Daniel Cryans <jdcryans@apache.org> wrote:

> From: Jean-Daniel Cryans <jdcryans@apache.org>
> Subject: Re: Write Operations on a Table Hangs
> To: user@hbase.apache.org
> Date: Thursday, April 28, 2011, 4:55 PM
> That message only means that the
> region is being flushed before it's closed.
> 
> When you say you can't write to it anymore, you mean at the
> moment of
> writing or if you let it alone for a few minutes and then
> come back
> would you be able to?
> 
> It's not a behavior that I remember seeing, it might just
> be your
> description that's different. In any case, I've never seen
> disabling a
> table really doing any good.
> 
> And which HBase version is that? What kind of cluster? Any
> special
> configuration? Anything about "blocking" in the logs?
> 
> Thx,
> 
> J-D
> 
> On Thu, Apr 28, 2011 at 12:52 PM, Harold Lim <rold_50@yahoo.com>
> wrote:
> > Hi All,
> >
> > Sometimes when I try to write to a table (I have a
> program that writes lots of rows to an hbase table), it
> hangs and then I can't write to the table anymore.
> > When I look at a region server's log, I see the
> message
> > 13:49:59,945 DEBUG
> org.apache.hadoop.hbase.regionserver.HRegion: waiting for
> cache flush to complete for region usertable
> >
> > I try to disable/drop the table using the hbase shell
> but it keeps saying that the table is not disabled.
> >
> > Any idea what's causing this?
> >
> > Thanks,
> > Harold
> >
> >
> 

Mime
View raw message