hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Ruchovets <oruchov...@gmail.com>
Subject Re: which hadoop and zookeeper version should I use with hbase 0.90.1
Date Wed, 16 Mar 2011 20:17:50 GMT
I get the src from here.

http://svn.apache.org/repos/asf/hadoop/common/branches/branch-0.20-append/



On Wed, Mar 16, 2011 at 7:40 PM, Stack <stack@duboce.net> wrote:

> From where did you get the src?
> Thanks,
> St.Ack
>
> On Wed, Mar 16, 2011 at 7:12 AM, Oleg Ruchovets <oruchovets@gmail.com>
> wrote:
> > On Mon, Feb 28, 2011 at 8:11 PM, Stack <stack@duboce.net> wrote:
> >
> >> On Sun, Feb 27, 2011 at 1:31 PM, Oleg Ruchovets <oruchovets@gmail.com>
> >> wrote:
> >> > Hi ,
> >> >   sorry for asking the same question couple of times , but I still
> have
> >> no
> >> > clear understanding which hadoop version I have to install for hbase
> >> 0.90.1.
> >> > Any  information will be really appreciated
> >> >
> >>
> >> Yeah, our version story is a little messy at the moment.  Would
> >> appreciate any input that would help us make it more clear.  More
> >> below...
> >>
> >>
> >> > 1)  From http://hbase.apache.org/notsoquick.html#hadoop I understand
> >> that
> >> > hadoop-0.20-append is an official version for hbase. I case I am going
> to
> >> > compile it : Do I have checkout main branch or there is a recomended
> tag?
> >> > If someone already compiled this version and had an issues please
> share
> >> it.
> >> >
> >>
> >> So, the documentation says " No official releases have been made from
> >> this branch up to now so you will have to build your own Hadoop from
> >> the tip of this branch.", so yes, you'll have to build it.  The
> >> branch-0.20-append link in the documentation is to the branch in SVN
> >> that you'd need to checkout and build.  This was not obvious to you so
> >> I need to reword this paragraph to be more clear.   How about if I
> >> insert after the above sentence "Checkout this branch [with a link to
> >> the branch in svn] and then compile it by..."  Would that be better?
> >>
> >>
> >> >
> >> > 2) I found cloudera maven repository and I see there only
> hadoop-0.20.2
> >> > version. Does this version supports durability and suitable for hbase
> >> > 0.90.1? or I need to copy jars from hadoop-0.20-append to
> hadoop-0.20.2
> >> > cloudera version? I looked for CDH3 and CDH4 but didn't find
> >> > hadoop-0.20-append version.
> >>
> >>
> >> Again, the documentation must be insufficiently clear here.  We link
> >> to the CDH3 page.  We also state it beta.  What would you suggest?
> >>
> >>
> >> > Question: does cloudera hadoop version (0.20.2) is suitable for hbase
> >> > 0.90.1?
> >>
> >>
> >> CDH3b2,CDH3b3, or CDH3b4 are all suitable (each is an hadoop 0.20.2++).
> >>
> >>
> >> > In case I am going to use cloudera do I need to install all parts
> >> (hadoop,
> >> > hbase ,zookeper ...) from cloudera or it is possible to take only
> hadoop
> >> > installation and other products  (hbase , zookeper) I can install from
> >> > standard distributions?
> >> >
> >> Any of above combinations should work.  If you use CDH3b4, you can
> >> take all from CDH since it includes 0.90.1.  Otherwise, you could use
> >> CDH hadoop and use your hbase build for the rest.
> >>
> >> St.Ack
> >>
> >
> >
> > It took some time , but we succeeded to compile hadoop version. We
> decided
> > to take an official version for hbase.
> >    I am only concern  about version which we get after compilation.
> > The version is *0.20.3-SNAPSHOT, r1057313. *
> > *   Does this version is a suitable version for hbase?*
> > *
> > *
> > Thanks in advance , Oleg.
> > *
> > *
> > *
> > *
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message