hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vishal Kapoor <vishal.kapoor...@gmail.com>
Subject Re: problem bringing Hbase back up after power outage and removal of nodes
Date Thu, 17 Mar 2011 18:12:27 GMT
you should have more info on why dfs is in the safe mode in the logs,
you can always leave safe mode

hadoop dfs -safemode leave

but again, thats a symptom, not a problem.

Vishal

On Thu, Mar 17, 2011 at 1:55 PM, Taylor, Ronald C <ronald.taylor@pnl.gov>wrote:

> Folks,
>
> We had a power outage here, and we are trying to bring our Hadoop/HBase
> cluster back up. Hadoop has been just fine - came up smoothly. HBase has
> not. Our HBase master log file is filled with just one msg:
>
> 2011-03-17 10:50:08,712 INFO org.apache.hadoop.hbase.util.FSUtils: Waiting
> for dfs to exit safe mode...
> 2011-03-17 10:50:18,714 INFO org.apache.hadoop.hbase.util.FSUtils: Waiting
> for dfs to exit safe mode...
>
> After the power outage, before we tried bringing things back up, we took
> several nodes off-line, as their hard drives were failing and needed
> replacing. Don't know if the loss of those nodes has anything to do with the
> error msg that we are seeing.
>
> Could anybody give us some advice as to where to look for the cause of the
> HBase failure? We would very much appreciate guidance.
>
> Ron
>
> Ronald Taylor, Ph.D.
> Computatational Biology & Bioinformatics Group
> Pacific Northwest National Laboratory (U.S. Dept of Energy/Battelle)
> Richland, WA 99352
> phone: (509) 372-6568
> email: ronald.taylor@pnl.gov
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message