hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Region server crashes when using replication
Date Sun, 27 Mar 2011 17:05:30 GMT
So the message "No log to process" means that nothing was assigned to
replicate at all... I wonder if it's HBASE-3664 that did that... but
you should be able to confirm by looking at the region server log when
it starts, it should be adding it's own HLog to the list to replicate.

Regarding the failover, it might be that the log is indeed registered
in zookeeper but somehow isn't in the memory log structure of
ReplicationSourceManager... again the logs should tell.

Feel free to send me directly a big tar.gz with all those logs and I
should be able to figure out.

Thx!

J-D

On Sun, Mar 27, 2011 at 2:21 AM, Eran Kutner <eran@notspammer.com> wrote:
> Had more time to look into it and verify that indeed data is not replicated
> because the server doesn't see it in the log. So I tried restarting the RS
> and sure enough when the table (which has only one region) transitioned to
> another RS the replication started working (for new data only).
> So I tried with another table, and same thing, replication doesn't work and
> the logs says "No log to process" but after restarting the RS and a table
> transition the replication started working for that table too. Is there
> something that gets initialized during a transition that could be missing
> before?
>
> -eran
>
>
>

Mime
View raw message