hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cosmin Lehene <cleh...@adobe.com>
Subject Re: I lost the table '.META.' ,could I restore the other tables by files of hdfs
Date Wed, 30 Mar 2011 09:19:24 GMT
Yep,

Just checked out 0.20 and tried it.

Look into add_table.rb

# Get table name
tableName = nil
if ARGV.size > 1
  tableName = ARGV[1]
  raise IOError.new("Not supported yet")
elsif


You can't provide a table name. Run the script with just the path to the table (no table name
as the second argument)

It worked.

Good luck,
Cosmin

On Mar 30, 2011, at 11:34 AM, 陈加俊 wrote:

Any hints?

On Wed, Mar 30, 2011 at 3:40 PM, 陈加俊 <cjjvictory@gmail.com<mailto:cjjvictory@gmail.com>>
wrote:
Thank you

bin/hbase org.jruby.Main bin/add_table.rb /hbase/cjjProgramme cjjProgramme
bin/add_table.rb:80: Not supported yet (IOError)

My HBase's version is 0.20.6 and HDFS version is 0.20.2.

On Wed, Mar 30, 2011 at 3:15 PM, Cosmin Lehene <clehene@adobe.com<mailto:clehene@adobe.com>>
wrote:
Hi Jiajun,

There's a script in hbase/bin to add a table: you can run bin/hbase org.jruby.Main bin/add_table.rb

Also there's a setting for HDFS to enable trash. This way your files won't get directly deleted,
but rather moved the Trash. You can later restore them or purge them (see HDFS doc

Good luck,
Cosmin

On Mar 30, 2011, at 10:06 AM, 陈加俊 wrote:

> Some body execute the command : /app/cloud/hadoop/bin/hadoop fs -rmr
> /hbase/.META.
>
> So the regions of all tables is lost ,Can I rebuild the tables by hdfs files
> ?
>
> --
> Thanks & Best regards
> jiajun




--
Thanks & Best regards
jiajun




--
Thanks & Best regards
jiajun


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message