hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Hendrey" <ghend...@decarta.com>
Subject RE: 0.90.1 hbase-default.xml
Date Fri, 04 Mar 2011 23:10:47 GMT
Any advise on this one? It occurs when I start HBase, then the master
shuts off. I am running hadoop-0.20.3-dev for hdfs. ClientProtocol
version mismatch. (client = 42, server = 41). I suppose it means that
some hdfs client/server protocol is incompatible, but I thought that
HBase 0.90.1 would work with 20.x hadoop

2011-03-04 14:57:13,357 FATAL org.apache.hadoop.hbase.master.HMaster:
Unhandled exception. Starting shutdown.
org.apache.hadoop.ipc.RPC$VersionMismatch: Protocol
org.apache.hadoop.hdfs.protocol.ClientProtocol version mismatch. (client
= 42, server = 41)
	at org.apache.hadoop.ipc.RPC.getProxy(RPC.java:364)
	at
org.apache.hadoop.hdfs.DFSClient.createRPCNamenode(DFSClient.java:113)
	at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:215)
	at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:177)
	at
org.apache.hadoop.hdfs.DistributedFileSystem.initialize(DistributedFileS
ystem.java:82)
	at
org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:1378)
	at
org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:66)
	at
org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:1390)
	at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:196)
	at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:95)
	at
org.apache.hadoop.hbase.master.MasterFileSystem.<init>(MasterFileSystem.
java:87)
	at
org.apache.hadoop.hbase.master.HMaster.finishInitialization(HMaster.java
:342)
	at org.apache.hadoop.hbase.master.HMaster.run(HMaster.java:278)
2011-03-04 14:57:13,359 INFO org.apache.hadoop.hbase.master.HMaster:
Aborting
2011-03-04 14:57:13,359 DEBUG org.apache.hadoop.hbase.master.HMaster:
Stopping service threads
2011-03-04 14:57:13,359 INFO org.apache.hadoop.ipc.HBaseServer: Stopping
server on 60000

-----Original Message-----
From: jdcryans@gmail.com [mailto:jdcryans@gmail.com] On Behalf Of
Jean-Daniel Cryans
Sent: Friday, March 04, 2011 2:53 PM
To: user@hbase.apache.org
Subject: Re: 0.90.1 hbase-default.xml

It's now included in the hbase jar so that people don't reuse them
between versions (since it led to many problems).

J-D

On Fri, Mar 4, 2011 at 2:44 PM, Geoff Hendrey <ghendrey@decarta.com>
wrote:
> Hi,
>
>
>
> I tried to use my hbase-default.xml from 0.89 with my new 0.90.1
> installation. I get a message stating "hbase-default.xml seems to be
> from an old version of hbase(null), this version is 0.90.1.
>
>
>
> But 0.90.1 doesn't seem to have an hbase-default.xml file that it
ships
> with (at least not in conf after I extracted the 0.90.1 .tar.gz file).
> So what is the process to get my configs up and running on 0.90.1.
>
>
>
> -g
>
>

Mime
View raw message