hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodrigo Barreto <rodbarr...@gmail.com>
Subject HBase crashes when one server goes down
Date Mon, 14 Feb 2011 17:58:28 GMT
Hi,

We are new with Hadoop, we have just configured a cluster with 3 servers and
everything is working ok except when one server goes down, the Hadoop / HDFS
continues working but the HBase stops, the queries does not return results
until we restart the HBase. The HBase configuration is copied bellow, please
help us.

########## HBASE-SITE.XML ###############

<configuration>
        <property>
                <name>hbase.zookeeper.quorum</name>
                <value>master,slave1,slave2</value>
                <description>The directory shared by region servers.
                </description>
        </property>
        <property>
                <name>hbase.rootdir</name>
                <value>hdfs://master:54310/hbase</value>
        </property>
        <property>
                <name>hbase.cluster.distributed</name>
                <value>true</value>
        </property>
        <property>
                <name>hbase.master</name>
                <value>master:60000</value>
                <description>The host and port that the HBase master runs
at.
                </description>
        </property>

        <property>
                <name>dfs.replication</name>
                <value>2</value>
                <description>Default block replication.
                The actual number of replications can be specified when the
file is created.
                The default is used if replication is not specified in
create time.
                </description>
        </property>
</configuration>


Thanks,

Rodrigo Barreto.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message