hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Inconsistent META data for a region.
Date Fri, 28 Jan 2011 19:06:03 GMT
On Fri, Jan 28, 2011 at 10:56 AM, Chris Howe <howech@infochimps.org> wrote:
> The region had been deployed, but I dropped the table before I tried to re-add
> it.
>

OK.  This could have been the cause.  Our disable/drop was flakey
pre-0.90.  Maybe it failed close out all regions.



> When I would stop a single regionserver that was hosting the phantom region, it
> would just migrate to a different one. I managed to get the warnings to
> completely go away for a time this morning, by shutting down all of the
> regionservers. Hbck came back clean.
>

It'd migrate without updating .META. w/ new location?


> Unfortunately, I then tried loading a large table that I had created as a set of
> HFiles, and when I ran "loadtable" on them, I was rewarded with 281 regions that
> are now on regionservers and not in META.
>

You are on a 0.89.x, are you?  If so, should you be using
completebulkload -- see http://hbase.apache.org/bulk-loads.html
(Sorry, there is a bit of overlap between completebulkload and
loadtable that is to be fixed.  completebulkload is the future).


>> > Is there a way that I can just zot these regions out and make hbase hbck
> happy
>> > again?
>>

hbck can take a while to settle.  It continues to report inconsistency?

Try stopping and starting your cluster.  That should take care of it.

Can you go to 0.90.0?

St.Ack

Mime
View raw message