hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mike anderson <saidthero...@gmail.com>
Subject Re: stargate 20.6 with hbase 20.2
Date Thu, 20 Jan 2011 21:04:45 GMT
I ended up copying hadoop-core from hadoop/20.2 and that seemed to fix it
(although it's still not up and running yet, debugging a few other issues).


-mike

On Thu, Jan 20, 2011 at 3:37 PM, mike anderson <saidtherobot@gmail.com>wrote:

> Thanks guys, everything appeared to go smoothly, but i'm getting stuck on
>
> Protocol org.apache.hadoop.hdfs.protocol.ClientProtocol version mismatch.
> (client = 42, server = 41)
>
> And thus the master won't start up. I upgraded Hadoop to 0.20.2. Anything
> to try aside from that? I googled around and only saw this error come up in
> the context of 0.90.0 rc2.
>
> Cheers,
> Mike
>
> On Thu, Jan 20, 2011 at 3:11 PM, Stack <stack@duboce.net> wrote:
>
>> Hey Mike: What Jon says.  You might want to check out yesterday's
>> announcment.  It has a paragraph on migration:
>>
>> http://www.apacheserver.net/ANN-HBase-0-90-0-available-for-download-at1114872.htm
>>
>> St.Ack
>>
>> On Thu, Jan 20, 2011 at 11:19 AM, Jonathan Gray <jgray@fb.com> wrote:
>> > The basic steps are the same, but to go from 0.20 to 0.90 there is no
>> actual "migrate" step.  On the HBase side, all that is required is shutting
>> down the old version and coming back up with the new version.  You need to
>> handle the Hadoop upgrade as well as laid out on that wiki page.
>> >
>> > You may want to backup your hbase directory on HDFS to be safe.  Once
>> you upgrade to 0.90 there is no easy way to go back unless you have a
>> backup.
>> >
>> > JG
>> >
>> >> -----Original Message-----
>> >> From: mike anderson [mailto:saidtherobot@gmail.com]
>> >> Sent: Thursday, January 20, 2011 11:01 AM
>> >> To: user@hbase.apache.org
>> >> Subject: Re: stargate 20.6 with hbase 20.2
>> >>
>> >> I couldn't find any specific migration instructions for 0.90.0 other
>> than
>> >> http://wiki.apache.org/hadoop/Hbase/HowToMigrate.
>> >>
>> >> Is this the case?
>> >>
>> >>
>> >>
>> >> On Thu, Jan 20, 2011 at 1:27 PM, mike anderson
>> >> <saidtherobot@gmail.com>wrote:
>> >>
>> >> > Thanks, decided to bite the bullet and just update to 0.90.0.
>> >> >
>> >> > Cheers,
>> >> > Mike
>> >> >
>> >> > On Thu, Jan 20, 2011 at 1:07 PM, Jonathan Gray <jgray@fb.com>
wrote:
>> >> >
>> >> >> It's strongly recommended that you upgrade to HBase 0.20.6 (at
>> least)
>> >> >> if not HBase 0.90.0.  There are several critical bug fixes in the
>> >> >> releases between 0.20.2 and 0.20.6 besides stargate.
>> >> >>
>> >> >> > -----Original Message-----
>> >> >> > From: mike anderson [mailto:saidtherobot@gmail.com]
>> >> >> > Sent: Thursday, January 20, 2011 9:57 AM
>> >> >> > To: hbase-user@hadoop.apache.org
>> >> >> > Subject: stargate 20.6 with hbase 20.2
>> >> >> >
>> >> >> > Does it seem reasonable that I could get Stargate 20.6 to
work
>> with
>> >> >> Hbase
>> >> >> > 20.2? I need some of the improvements made in 20.6, but would
>> >> >> > rather not have to upgrade my entire cluster if I don't have
to.
>> >> >> >
>> >> >> > -mike
>> >> >>
>> >> >
>> >> >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message