hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Laffoon" <mlaff...@semanticresearch.com>
Subject RE: Small error in (excellent) manual at: http://hbase.apache.org/docs/r0.20.6/cygwin.html
Date Thu, 27 Jan 2011 18:13:34 GMT
One problem I had is that the output of the ZKServerTool as used in
zookeepers.sh has to be piped through dos2unix. I have a little hack
script that fixes this for me:

  sed -ie "s/ZKServerTool\`/ZKServerTool | dos2unix\`/g"
"$HBASE_HOME/bin/zookeepers.sh"


-----Original Message-----
From: saint.ack@gmail.com [mailto:saint.ack@gmail.com] On Behalf Of Stack
Sent: Saturday, January 15, 2011 5:45 PM
To: user@hbase.apache.org
Subject: Re: Small error in (excellent) manual at:
http://hbase.apache.org/docs/r0.20.6/cygwin.html

It looks like the zookeeper ensemble has not started.  Is that possible?

2011-01-14 19:42:03,773 WARN org.apache.zookeeper.ClientCnxn:
Exception closing session 0x0 to sun.nio.ch.SelectionKeyImpl@76e8a7^M
java.net.ConnectException: Connection refused: no further information^M
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)^M
    at sun.nio.ch.SocketChannelImpl.finishConnect(Unknown Source)^M
    at
org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:933)^M

Is this standalone or pseudo-distributed or what?  Unless you tampered
with settings in hbase-env.sh, ZK should be started for you.  Check
out the .out file or if a zookeeper log beside this master log, check
that.

I see that windows would seem to set ulimit for files to 256 by
default.  Once you get things going, try and up that if you can.

St.Ack

On Fri, Jan 14, 2011 at 10:54 AM, Jérôme Verstrynge <jverstry@gmail.com>
wrote:
> On 14/01/2011 7:37, Stack wrote:
>>
>> Thank you for sending in the correction.  I will fix it soon unless you
>> would like to file an issue and patch yourself?
>
> Well, I am facing another issue now and I don't know whether it is
related
> to this one (...I don't think so, but...).
>
> When I try to run the create 'test', 'data' command in the shell, I'm
> getting an org.apache.hadoop.hbase.MasterNotRunningException:null.
>
> My googling indicates that I should check the logs, but I can't decode
the
> meaning (c.f. attachment).
>
> Can anyone explain what is happening?
>
> Thanks,
>
> JVerstry
>
>> Yours,
>> Stack
>>
>> On Jan 14, 2011, at 10:31, Jérôme Verstrynge<jverstry@gmail.com>
 wrote:
>>>
>>> Hi, I am a newbie to HBase.
>>>
>>> I am following the instructions to install Hbase at
>>> http://hbase.apache.org/docs/r0.20.6/cygwin.html. I have noticed a
small
>>> error.
>>>
>>> In the Java confirguration section, the tutorial says one should
create a
>>> link with:
>>>
>>> LN -s /cygdrive/c/Program\ Files/Java//<jre name>  //usr/local//<jre
>>> name>/
>>>
>>> But it should be
>>>
>>> LN -s /cygdrive/c/Program\ Files/Java//<jre name>  //usr/java//<jre
>>> name>/
>>>
>>> (one could also recommend creating the java dir in /usr before making
the
>>> link)
>>>
>>> Otherwise, one will get an error message like the one reported at:
>>>
http://mail-archives.apache.org/mod_mbox/hbase-dev/201006.mbox/%3CB6D7B6DE
449144409272440146381EE72E307B2F70@TENK7MVG.prod.travp.net%3E
>>> when running start-hbase.sh.
>>>
>>> My 2 cents,
>>>
>>> JVerstry
>
>

Mime
View raw message