hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gökhan Çapan <gkhn...@gmail.com>
Subject Re: Importing to HBase from Java problem
Date Wed, 08 Dec 2010 23:58:43 GMT
On Thu, Dec 9, 2010 at 12:44 AM, Stack <stack@duboce.net> wrote:

> On Wed, Dec 8, 2010 at 1:19 PM, Gökhan Çapan <gkhncpn@gmail.com> wrote:
> >
> > There is another module with exactly same dependencies. This is a "has
> > nothing but a main" class that performs some scans on the HBase table
> > produced in the previous step.
> >
> > after a mvn package with dependencies and adding the hbase-site.xml above
> as
> > a resource, with SimpleClient as main class, I couldn't java -jar
> > SimpleClient.jar, it gave me the exception I have posted.
> >
>
> So SimpleClient.jar has its dependencies in META-INF/MANIFEST.MF
> listed on the Class-Path line?  Is that how things are supposed to be
> working?  If so, do you see the right set of jars and an
> hbase-site.xml listed there.
>
> In general this mechanism is flakey IIRC since its all about relative
> paths; i.e. dependencies are found relative to where the program is
> launched from.
>

Yes i see, also the program does. It gives error SAXParseException in
org.apache.hadoop.conf.Configuration.loadResource for an invalid xml, for
example. Anyway, i probably make a silly mistake that i cannot recognize
now. I will struggle with it more.

Thanks for help.

>
> St.Ack
>



-- 
Gökhan Çapan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message