hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Haidinyak <phaidin...@local.com>
Subject Problem connecting to HBase using Java Client
Date Thu, 02 Dec 2010 20:19:41 GMT
Hidey Ho,
  I have a three node cluster up running
Hadoop 20.20.2+737.tar  (from Cloudera)
HBase  0.89.20100924+28 (from Cloudera)

When I do a JPS everything looks ok.

I am trying to connect to HBase using a Java Client.

    final Configuration config = HBaseConfiguration.create();
    m_trafficTable = new HTable(config, TRAFFIC_LOG_TABLE_NAME);
    m_trafficTable.setAutoFlush(false);  // performance
    m_trafficTable.setWriteBufferSize(12582912L);  // performance

When the client tries to create the configuration I get the following...

2010-12-02 11:35:59,971 INFO  [Import Click Log Thread] zookeeper.ZooKeeperWrapper(195): Reconnecting
to zookeeper
2010-12-02 11:36:00,033 DEBUG [Import Click Log Thread] zookeeper.ZooKeeperWrapper(201): <localhost:/hbase,org.apache.hadoop.hbase.client.HConnectionManager>Connected
to zookeeper again
2010-12-02 11:36:00,035 DEBUG [Import Click Log Thread] zookeeper.ZooKeeperWrapper(466): <localhost:/hbase,org.apache.hadoop.hbase.client.HConnectionManager>Trying
to read /hbase/root-region-server
2010-12-02 11:36:00,171 DEBUG [Import Click Log Thread] zookeeper.ZooKeeperWrapper(469): <localhost:/hbase,org.apache.hadoop.hbase.client.HConnectionManager>Failed
to read org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss
for /hbase/root-region-server
2010-12-02 11:36:00,172 DEBUG [Import Click Log Thread] client.HConnectionManager$TableServers(1077):
Sleeping 5000ms, waiting for root region.
2

This just repeats.

Any ideas?

Thanks

-Pete


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message