hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From samchan80 <samcha...@gmail.com>
Subject "No such file or directory" error from hbase-daemon.sh
Date Wed, 08 Dec 2010 22:04:53 GMT

I have been trying to set up HBase on Windows XP (SP3) with Cygwin. I
followed the "Installing HBase on Windows using Cygwin" documentation from 
http://hbase.apache.org/docs/current/cygwin.html#HBase-N10329
http://hbase.apache.org/docs/current/cygwin.html#HBase-N10329 .
I'm using JRE 6, Cygwin 1.7.7 and HBase 0.20.6.

The Cygwin, Java, HBase configuration seemed to go as expected. However,
Whenever I start HBase using "./bin/start-hbase.sh", I see the following
errors:

localhost: /usr/local/hbase-0.20.6/bin/hbase-daemon.sh: line 46: cd:
/usr/local/
: No such file or directory
localhost: /usr/local/hbase-0.20.6/bin/hbase-daemon.sh: line 48:
/usr/local/hbas
e-0.20.6/hbase-config.sh: No such file or directory


I have read various forums looking for a solution. I have made sure that all
my scripts have Unix-style line endings (LF) versus Windows-style (CR-LF).

What else could I be missing? It seems like whenever the scripts run through
SSH, this problem occurs for the line "bin=`cd "$bin"; pwd`" and other
similar lines.
When I run the same command through command-line, it works fine.

Please help. I'm frustrated that I haven't been able to proceed with the
simple setup steps that most other people seem to have no issues with. Also
if it helps, I encounter the SAME issues when trying to set up a single-node
Hadoop installation.
-- 
View this message in context: http://old.nabble.com/%22No-such-file-or-directory%22-error-from-hbase-daemon.sh-tp30410517p30410517.html
Sent from the HBase User mailing list archive at Nabble.com.


Mime
View raw message