hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sharma, Avani" <agsha...@ebay.com>
Subject tables lost when truncating another table
Date Mon, 13 Sep 2010 18:07:09 GMT
Here is a log of what I did as a result of which I do not see any tables.
TABLE1 is a relatively bigger table for my table sizes, but not by HBase standards. I had
loaded 15-20 versions of ~2G files into this table.

machine_name:~ hadoop$curl http://localhost:8080
TABLE1
TABLE2
TABLE3
TABLE4
machine_name:~ hadoop$hbase shell
HBase Shell; enter 'help<RETURN>' for list of supported commands.
Version: 0.20.6, r965666, Mon Jul 19 15:48:07 PDT 2010
hbase(main):002:0> truncate 'TABLE1'
Truncating TABLE1; it may take a while
Disabling table...
NativeException: org.apache.hadoop.hbase.RegionException: Retries exhausted, it took too long
to wait for the table TABLE1 to be disabled.

hbase(main):003:0> disable 'TABLE1'
NativeException: org.apache.hadoop.hbase.RegionException: Retries exhausted, it took too long
to wait for the table TABLE1 to be disabled.

hbase(main):004:0> disable 'TABLE1'
NativeException: org.apache.hadoop.hbase.TableNotFoundException: TABLE1

hbase(main):005:0> truncate 'TABLE1'
NativeException: java.lang.NullPointerException: null

hbase(main):006:0> list
0 row(s) in 6.0320 seconds
hbase(main):007:0> exit
machine_name:~ hadoop$curl http://localhost:8080
machine_name:~ hadoop$

Thanks,
Avani Sharma



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message