hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Helmling <ghelml...@gmail.com>
Subject Re: Hbase 0.89-hadoop version mismatch errors..
Date Wed, 18 Aug 2010 05:36:29 GMT
On Tue, Aug 17, 2010 at 7:39 PM, Vidhyashankar Venkataraman <
vidhyash@yahoo-inc.com> wrote:

> When I try to start HBAse 0.89 along with Hadoop 0.20.100, Hbase fails to
> start up with these errors in the namenode whioch leads to exceptions in
> master and regionservers..
>
>
When you say Hadoop 0.20.100, do you mean the yahoo-0.20.100 github branch,
with backported security features?

If so, HBase 0.89 will not currently run on it due to incompatible changes
to security related classes (UserGroupInformation interface changes, removal
of UnixUserGroupInformation class) that were also used in HBase.

I have a work-in-progress branch on github that ports over some of the
security changes here:
http://github.com/ghelmling/hbase/tree/security

What's there is experimental, and not fully tested, though.  And it still
needs work before being proposed for actual inclusion.  But it should work
for testing, depending on your needs.

--gh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message