hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vidhyashankar Venkataraman <vidhy...@yahoo-inc.com>
Subject Bulk load problems..
Date Mon, 14 Jun 2010 18:08:00 GMT
I tried dumping my own Hfiles (similar to HFileOutputFormat: open an Hfile.writer, append the
key value pairs and then close the writer) and tried loading them using the ruby script..
 I had altered loadtable.rb to modify the block size for the column family.

The script reported no errors. But on checking with the web interface,  (table's name is DocData)
http://b5120231.yst.yahoo.net:60010/table.jsp?name=DocData

I got this:
org.apache.hadoop.hbase.client.NoServerForRegionException: No server address listed in .META.
for region DocData,,1276537980228

And in each region server, I got this
2010-06-14 17:57:48,846 ERROR org.apache.hadoop.hbase.regionserver.HRegionServer: Error opening
DocData,0000133832,1276537980224
java.lang.IllegalAccessError: Has not been initialized
        at org.apache.hadoop.hbase.regionserver.StoreFile.getMaxSequenceId(StoreFile.java:216)
        at org.apache.hadoop.hbase.regionserver.Store.loadStoreFiles(Store.java:417)
        at org.apache.hadoop.hbase.regionserver.Store.<init>(Store.java:221)
        at org.apache.hadoop.hbase.regionserver.HRegion.instantiateHStore(HRegion.java:1549)
        at org.apache.hadoop.hbase.regionserver.HRegion.initialize(HRegion.java:312)
        at org.apache.hadoop.hbase.regionserver.HRegionServer.instantiateRegion(HRegionServer.java:1564)
        at org.apache.hadoop.hbase.regionserver.HRegionServer.openRegion(HRegionServer.java:1531)
        at org.apache.hadoop.hbase.regionserver.HRegionServer$Worker.run(HRegionServer.java:1451)
        at java.lang.Thread.run(Thread.java:619)


I am using Hbase 0.20.3... Have I made a mistake while dumping Hfiles?

Vidhya

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message