hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergio Bossa <sergio.bo...@gmail.com>
Subject Re: java.lang.UnsupportedClassVersionError with JDK 1.6.0_17
Date Fri, 11 Jun 2010 08:37:07 GMT
On Thu, Jun 10, 2010 at 10:49 PM, Ryan Rawson <ryanobjc@gmail.com> wrote:

> In /Applications/Utilities there is an app called "Java Preferences"
> which allows you to choose the 'default' VM for the entire OS.  You
> can check this by first doing :
>
> java -version

Java 1.6 is the only enabled JVM in that preference pane (I set it up
this way): in fact, "java -version" gives me the 1.6 message.

> 10.6 contains both Java 1.5 and 1.6.  However 1.5 is NOT (nor will be)
> 64 bit.  And Java 1.6 doesn't contain carbon/UI connectivity.
> Practically speaking it means you have to mess with the eclipse setup
> to _run_ with java 1.5, but use the 1.6 VM to build.  IntelliJ handles
> this automatically.

It's not an IDE-related problem: it's a startup scripts problem.

-- 
Sergio Bossa
http://www.linkedin.com/in/sergiob

Mime
View raw message