hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raghava Mutharaju <m.vijayaragh...@gmail.com>
Subject Re: Zookeeper exception - ConnectionLoss for /hbase
Date Wed, 09 Jun 2010 00:00:30 GMT
Will it do if $HBASE_HOME/conf (directory containing hbase-site.xml) is in
HADOOP_CLASSPATH of hadoop-env.sh file??

Regards,
Raghava.

On Tue, Jun 8, 2010 at 7:51 PM, Jonathan Gray <jgray@facebook.com> wrote:

> Is the directory containing hbase-site.xml in the classpath of your client?
>
> > -----Original Message-----
> > From: Raghava Mutharaju [mailto:m.vijayaraghava@gmail.com]
> > Sent: Tuesday, June 08, 2010 4:39 PM
> > To: user@hbase.apache.org
> > Subject: Zookeeper exception - ConnectionLoss for /hbase
> >
> > Hi all,
> >
> >        I am using HBase API to insert data into a table on a cluster. I
> > am
> > getting the following exception (full stack trace in pastebin, link
> > given
> > below).
> >
> > [java] 10/06/08 05:02:15 WARN zookeeper.ZooKeeperWrapper: Failed to
> > create
> > /hbase -- check quorum servers, currently=localhost:2181
> > [java] org.apache.zookeeper.KeeperException$ConnectionLossException:
> > KeeperErrorCode = ConnectionLoss for /hbase
> >
> > http://pastebin.com/tuwd0dgb
> >
> >
> > Looks like it is considering localhost as the ZooKeeper server. But I
> > did
> > give 3 comma separated machine names for hbase.zookeeper.quorum
> > property in
> > hbase-site.xml. Am I missing some other setting?
> >
> > Thank you.
> >
> > Regards,
> > Raghava.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message