hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Segel <michael_se...@hotmail.com>
Subject RE: More silly questions ... part deux... Need Response ASAP.
Date Wed, 17 Mar 2010 04:10:44 GMT


Thanks for the quick response...

Yes, we had it, but unfortunately when I did the upgrade to the patch, the directory appeared
to be overwritten, however I just edited it to point to /etc/hbase-0.20/conf which a symbolic
link to our cloud's configuration.

But now I do have another issue...
10/03/16 23:03:53 INFO mapred.JobClient:  map 0% reduce 0%
10/03/16 23:04:37 INFO mapred.JobClient: Task Id : attempt_201003162200_0004_m_000001_0, Status
: FAILED
Error: java.lang.ClassNotFoundException: org.apache.zookeeper.Watcher
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at org.apache.hadoop.hbase.client.HConnectionManager.getClientZooKeeperWatcher(HConnectionManager.java:170)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.getZooKeeperWrapper(HConnectionManager.java:932)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRootRegion(HConnectionManager.java:948)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:625)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:601)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:675)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:634)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:601)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:675)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:638)
        at org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:601)
        at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:128)
        at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:106)
        at org.apache.hadoop.hbase.mapreduce.TableInputFormat.setConf(TableInputFormat.java:87)
        at org.apache.hadoop.util.ReflectionUtils.setConf(ReflectionUtils.java:62)
        at org.apache.hadoop.util.ReflectionUtils.newInstance(ReflectionUtils.java:117)
        at org.apache.hadoop.mapred.MapTask.runNewMapper(MapTask.java:536)

So 
I'm guessing one of my config entries are still not set correctly. :-(
But getting closer...

-Mike
> Date: Tue, 16 Mar 2010 19:32:45 -0700
> Subject: Re: More silly questions ... part deux... Need Response ASAP.
> From: ryanobjc@gmail.com
> To: hbase-user@hadoop.apache.org
> 
> Did You include $HBASE_HOME/conf as per the docs?
> 
> On Mar 16, 2010 7:25 PM, "Michael Segel" <michael_segel@hotmail.com> wrote:
> 
> 
> Ok,
> 
> Part 1, when I upgraded to the patched version, I forgot to push out the
> upgraded hadoop-env.sh environment.
> (the jar files' names changed.)
> 
> Now here's the next 'brain dead' thing I probably missed.
> 
> When I start the job, its now finding the jars, but the environment
> configuration isn't being found.
> Its attempting to connect to zookeeper on the local host and not where hbase
> identifies the quorum.
> 
> I know its a simple step we've overlooked and I'm about ready to do my next
> Homer Simpson moment.
> 
> Thx
> 
> -Mike
> 
> 
> 
> _________________________________________________________________
> Hotmail: Trusted email with Microsoft’s powerful SPAM protection.
> http://clk.atdmt.com/GBL/go/210850552/direct/01/
 		 	   		  
_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
http://clk.atdmt.com/GBL/go/210850553/direct/01/
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message