hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel Gutin <pavelgu...@gmail.com>
Subject Can get HBase to work on RedHat, even though it works on Ubuntu
Date Fri, 29 Jan 2010 17:18:09 GMT
I apologize if I am breaking some kind of list etiquette, but I've
been struggling for the last week, and I have no idea where to ask for
help.

I got HBase to work on my virtual Ubuntu machine, but when i tried
moving it to RedHat running on real hardware, it fails. I start up
hadoop, then zookeeper and when i start HBase, i get the following
error:

>$ bin/start-hbase.sh
localhost: starting zookeeper, logging to
/usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-zookeeper-fchadoop04.out
localhost: java.net.BindException: Address already in use
localhost:      at sun.nio.ch.Net.bind(Native Method)
localhost:      at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
localhost:      at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
localhost:      at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
localhost:      at
org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:140)
localhost:      at
org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:106)
localhost:      at
org.apache.hadoop.hbase.zookeeper.HQuorumPeer.runZKServer(HQuorumPeer.java:90)
localhost:      at
org.apache.hadoop.hbase.zookeeper.HQuorumPeer.main(HQuorumPeer.java:75)
starting master, logging to
/usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-master-fchadoop04.out
localhost: starting regionserver, logging to
/usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-regionserver-fchadoop04.out

When I go into the shell after that, doing anything throws a
"MasterNotRunningException"

I would appreciate any help.

 - Pavel

Mime
View raw message