hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Something Something <mailinglist...@gmail.com>
Subject Re: Exception after upgrading to 0.20.2
Date Wed, 02 Dec 2009 19:51:12 GMT
Good thinking, Vaibhav :)  I had the old hbase-0.20.0.jar file in my
/hadoop/lib directory.  I removed that, added the new one and now it's
working.

Need to figure out a better way to do this.  My bad!

Does everyone copy files like this in /hadoop/lib I wonder!

Anyway, thanks for your help.



On Wed, Dec 2, 2009 at 11:07 AM, Vaibhav Puranik <vpuranik@gmail.com> wrote:

> Are you using 20.2 client?
> Please make sure that you use the client with the same version as the
> server.
>
> Reagrds,
> Vaibhav
>
> On Wed, Dec 2, 2009 at 10:09 AM, Something Something <
> mailinglists19@gmail.com> wrote:
>
> > Hello,
> >
> > After upgrading HBase from 0.20.0 to 0.20.2 I am getting following error
> > message:
> >
> > java.lang.reflect.UndeclaredThrowableException
> > at $Proxy2.getRegionInfo(Unknown Source)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRootRegion(HConnectionManager.java:931)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:573)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:549)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:623)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:582)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:549)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegionInMeta(HConnectionManager.java:623)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:586)
> > at
> >
> >
> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.locateRegion(HConnectionManager.java:549)
> > at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:125)
> > at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:103)
> > at com.xxxx.OrderLoader$CustomerReducer.setup(OrderLoader.java:81)
> > at org.apache.hadoop.mapreduce.Reducer.run(Reducer.java:172)
> > at org.apache.hadoop.mapred.ReduceTask.runNewReducer(ReduceTask.java:563)
> > at org.apache.hadoop.mapred.ReduceTask.run(ReduceTask.java:408)
> > at org.apache.hadoop.mapred.Child.main(Child.java:170)
> > Caused by: org.apache.hadoop.ipc.RemoteException: java.io.IOException:
> > java.lang.NullPointerException
> >
> > at org.apache.hadoop.hbase.ipc.HBaseClient.call(HBaseClient.java:723)
> > at org.apache.hadoop.hbase.ipc.HBaseRPC$Invoker.invoke(HBaseRPC.java:328)
> > ... 17 more
> >
> > This is happening for the following line in my code:
> >
> > this.table = new HTable(new HBaseConfiguration(), tableName);
> >
> > This used to work flawlessly before, so seems like something changed in
> > HBaseConfiguration, may be?  I am looking into this, but any pointers
> would
> > be greatly appreciated.
> >
> >
> > Thanks.
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message