hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio D'Ettole" <coda...@gmail.com>
Subject Re: Zookeper not found in the classpath?
Date Thu, 26 Nov 2009 14:25:58 GMT
Lars,
you are absolutely right. I forgot to restart MapReduce.
Thanks.
Antonio

On Thu, Nov 26, 2009 at 3:09 PM, Lars George <lars@worldlingo.com> wrote:

> Hi Antonio,
>
> Are you sure you copied the right hadoop-env.sh to all cluster nodes and
> restarted the MapReduce framework (with stop-mapred.sh and start-mapred.sh)?
>
> Also you should try first running the row counter as a Driver like so:
>
> ./bin/hadoop <path-to-hbase>/hbase-0.20.2jar rowcounter mytable colfam1
> colfam2 ...
>
> It needs to have some columns to scan or else it will report a NPE later in
> the TableInputFormat.
>
> Lars
>
>
> Antonio D'Ettole schrieb:
>
>  Hi folks,
>> I was trying to run the RowCounter example on my hadoop cluster. I
>> followed
>> the instructions at
>>
>> http://hadoop.apache.org/hbase/docs/current/api/org/apache/hadoop/hbase/mapreduce/package-summary.htmland
>> modified my HADOOP_CLASSPATH . I can tell this works because by
>> invoking
>>
>>
>> ./bin/hadoop org.apache.hadoop.hbase.mapreduce.RowCounter mytable
>>
>> the rowcounter example starts and the job is submitted to the jobtracker.
>> Alas, all task attempts exit with this exception:
>>
>> Error: java.lang.ClassNotFoundException: org.apache.zookeeper.Watcher
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>> at java.security.AccessController.doPrivileged(Native Method)
>>        [............]
>>
>> I'm _sure_ I added the right zookeper library to the path because when I
>> remove it the process exits immediately with the exception
>>
>> Exception in thread "main" java.lang.NoClassDefFoundError:
>> org/apache/zookeeper/Watcher
>>
>> and the process isn't even launched. By putting the jar file back into the
>> classpath, the job is submitted and started but i'm back to the first
>> exception. Does anyone have an idea what I could be doing wrong?
>>
>> Thanks
>>
>> Antonio
>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message