hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Helmling <ghelml...@gmail.com>
Subject Re: stackoverflow error
Date Thu, 29 Oct 2009 01:38:56 GMT
I just updated to 0.20.1 and think that I'm seeing this as well.

Here's a sample of the client log: http://pastebin.com/m549fbcfa
and a sample of the regionservers: http://pastebin.com/m5a8e89c3

Best I can tell, it seems to be data related in that it's reproducible with
gets on specific rows.  Other rows in the same region work normally.



On Wed, Oct 28, 2009 at 9:25 PM, Jean-Daniel Cryans <jdcryans@apache.org>wrote:

> BTW this is https://issues.apache.org/jira/browse/HBASE-1781
>
> J-D
>
> On Wed, Oct 28, 2009 at 6:24 PM, Ananth T. Sarathy
> <ananth.t.sarathy@gmail.com> wrote:
> > It's not advancing. I am not sure how you tell which region...
> > here is some of the output from the shell
> > http://pastebin.org/49134
> >
> >
> > Where can I look for that info
> > Ananth T Sarathy
> >
> >
> > On Wed, Oct 28, 2009 at 6:24 PM, stack <stack@duboce.net> wrote:
> >
> >> Same region over and over?  Then it ain't advancing?  Or does it vary?
> >> St.Ack
> >>
> >> On Wed, Oct 28, 2009 at 3:09 PM, Ananth T. Sarathy <
> >> ananth.t.sarathy@gmail.com> wrote:
> >>
> >> > ok... I  when I try to do i straight countin the shell
> >> > I get
> >> >
> >> >
> >> > 09/10/28 18:08:56 DEBUG client.HTable$ClientScanner: Advancing
> internal
> >> > scanner to startKey at
> >> >
> >> >
> >>
> 'FileZilla\x203.2.33.2.3http:\x2F\x2Ffilehippo.com\x2Fdownload_filezilla\x2F5408\x2
> >> >
> >> > which has been repeating for a while...
> >> > Ananth T Sarathy
> >> >
> >> >
> >> > On Wed, Oct 28, 2009 at 5:08 PM, stack <stack@duboce.net> wrote:
> >> >
> >> > > You using a filter of some kind?   What kinda scan is it?  Are you
> on
> >> > > latest
> >> > > hbase?  Easy way to check healthyness is scan of the table.  Use
> count
> >> in
> >> > > shell or rowcounter mr job.  If you are just doing straight scan,
> then
> >> > > something is up.  Looks at the 0.20.1 bug fixes to see if any
> address a
> >> > > stackoverflow issue.  Otherwise, try to figure why its happening for
> >> you
> >> > > and
> >> > > not for the rest of us.
> >> > > St.Ack
> >> > >
> >> > > On Wed, Oct 28, 2009 at 1:51 PM, Ananth T. Sarathy <
> >> > > ananth.t.sarathy@gmail.com> wrote:
> >> > >
> >> > > > I am getting a stackoverflow error while I am iterating through
a
> >> table
> >> > > > scan
> >> > > >
> >> > > > http://pastebin.com/mc940416
> >> > > >
> >> > > > is there any maintiance type task I should run to make my
> >> regionservers
> >> > > are
> >> > > > all copacetic?
> >> > > >
> >> > > > Ananth T Sarathy
> >> > > >
> >> > >
> >> >
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message