hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murali Krishna. P" <muralikpb...@yahoo.com>
Subject Re: Issue with bulk loader tool
Date Fri, 30 Oct 2009 16:01:10 GMT
Attached ".META"

Interesting, I was able to get the row from HTable via java code. But from the shell, still
getting following

hbase(main):004:0> get 'TestTable2', 'ffffef95bcbf2638'
0 row(s) in 1.2250 seconds
 
Thanks,
Murali Krishna

 Thanks,
Murali Krishna




________________________________
From: stack <stack@duboce.net>
To: hbase-user@hadoop.apache.org
Sent: Fri, 30 October, 2009 8:39:46 PM
Subject: Re: Issue with bulk loader tool

Can you send a listing of ".META."?

hbase> scan ".META."

Also, can you bring a region down from hdfs, tar and gzip it, and then put
it someplace I can pull so I can take a look?

Thanks,
St.Ack


On Fri, Oct 30, 2009 at 3:31 AM, Murali Krishna. P
<muralikpbhat@yahoo.com>wrote:

> Hi guys,
>  I created a table according to hbase-48. A mapreduce job which creates
> HFiles and then used loadtable.rb script to create the table. Everything
> worked fine and i was able to scan the table. But when i do a get for a key
> displayed in the scan output, it is not retrieving the row. shell says 0
> row.
>
>  I tried using one reducer to ensure total ordering, but still same issue.
>
>
> My mapper is like:
>   context.write(new
> ImmutableBytesWritable(((Text)key).toString().getBytes()), new
> KeyValue(((Text)key).toString().getBytes(), "family1".getBytes(),
>                    "column1".getBytes(), getValueBytes()));
>
>
> Please help me investigate this.
>
> Thanks,
> Murali Krishna
>

Mime
View raw message