hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <saint....@gmail.com>
Subject Re: Hbase Client problem
Date Sat, 12 Sep 2009 01:17:33 GMT
If ubuntu, why all the windows style pathes?



On Sep 11, 2009, at 6:00 PM, David Perona <davidperona@yahoo.com> wrote:

> I am beginning to think it is some sort of network problem even  
> though I can use the web UIs from the client.  I am only running the  
> client/Jboss on my laptop with a VM running Ubuntu 9.0.4 with Hadoop/ 
> Hbase.
>
> The STDOUT was just printing the HBaseConfiguration file as a string.
>
> JBOSS just wants to talk to Hbase.
>
> What is the minimum I information I need on the client to talk to  
> hbase?  I have the 3 jars listed below and the hbase-site.xml  
> without anything else that I know of on the client.  I searched and  
> removed any hadoop and hbase files or references on the client.   
> Here's my client hbase-site.xml:
>
> <configuration>
> <property>
>  <name>hbase.zookeeper.quorum</name>
>  <value>user-laptop</value>
> </property>
> <property>
>  <name>hbase.rootdir</name>
>  <value>hdfs://user-laptop:9000/hbase</value>
> </property>
> </configuration>
>
> I am calling it a night and looking at it again tomorrow.
>
> Thanks for your help.
>
> DP
>
>
> ----- Original Message ----
> From: stack <stack@duboce.net>
> To: hbase-user@hadoop.apache.org
> Sent: Friday, September 11, 2009 6:46:27 PM
> Subject: Re: Hbase Client problem
>
> If the CLASSPATH is ordered as per the output below on the line  
> STDOUT, then
> hbase-default is perhaps being read before hbase-site so default  
> values are
> being found instead of your customizations?  This JBOSS client is  
> trying to
> talk to hbase or launch mapreduce jobs?
> St.Ack
>
> On Fri, Sep 11, 2009 at 4:26 PM, David Perona  
> <davidperona@yahoo.com> wrote:
>
>> I replaced all ips with host names in hadoop/hbase and got the same
>> behavior.  Any other thoughts?
>>
>> Jboss console:
>> 18:18:55,183 INFO [STDOUT] config=Configuration: core-default.xml,
>> core-site.xml, hbase-default.xml, hbase-site.xml, C:/dev/hbase- 
>> site.xml
>> 18:18:55,356 INFO [ZooKeeper] Client
>> environment:zookeeper.version=3.2.0--1, built on 05/15/2009 06:05 GMT
>> 18:18:55,357 INFO [ZooKeeper] Client environment:host.name=
>> d1-laptop.gateway.2wire.net
>> 18:18:55,357 INFO [ZooKeeper] Client  
>> environment:java.version=1.6.0_14
>> 18:18:55,357 INFO [ZooKeeper] Client environment:java.vendor=Sun
>> Microsystems Inc.
>> 18:18:55,357 INFO [ZooKeeper] Client environment:java.home=C: 
>> \Program Files
>> (x86)\Java\jre6
>> 18:18:55,357 INFO [ZooKeeper] Client environment:java.class.path=C: 
>> \JBOSS\
>> jboss-5.1.0.GA\bin\run.jar
>> 18:18:55,357 INFO [ZooKeeper] Client
>> environment:java.io.tmpdir=C:\Users\owner\AppData\Local\Temp\
>> 18:18:55,357 INFO [ZooKeeper] Client environment:java.compiler=<NA>
>> 18:18:55,357 INFO [ZooKeeper] Client environment:os.name=Windows  
>> Vista
>> 18:18:55,358 INFO [ZooKeeper] Client environment:os.arch=x86
>> 18:18:55,358 INFO [ZooKeeper] Client environment:os.version=6.0
>> 18:18:55,358 INFO [ZooKeeper] Client environment:user.name=owner
>> 18:18:55,358 INFO [ZooKeeper] Client environment:user.home=C:\Users 
>> \owner
>> 18:18:55,358 INFO [ZooKeeper] Client environment:user.dir=C:\JBOSS\
>> jboss-5.1.0.GA\bin
>> 18:18:55,360 INFO [ZooKeeper] Initiating client connection,
>> host=user-laptop:2181 sessionTimeout=60000
>> watcher=org.apache.hadoop.hbase.client.HConnectionManager 
>> $ClientZKWatcher@1abf27c
>> 18:18:55,364 INFO [ClientCnxn] zookeeper.disableAutoWatchReset is  
>> false
>> 18:18:56,262 INFO [ClientCnxn] Attempting connection to server user- 
>> laptop/
>> 192.168.1.68:2181
>> 18:18:56,275 INFO [ClientCnxn] Priming connection to
>> java.nio.channels.SocketChannel[connected local=/ 
>> 192.168.1.65:63498remote=user-laptop/
>> 192.168.1.68:2181]
>> 18:18:56,285 INFO [ClientCnxn] Server connection successful
>> 18:18:58,471 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:44915. Already tried 0 time(s).
>> 18:19:00,511 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:44915. Already tried 1 time(s).
>> 18:19:02,510 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:44915. Already tried 2 time(s).
>> 18:19:04,510 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:44915. Already tried 3 time(s).
>> 18:19:06,520 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:44915. Already tried 4 time(s).
>> 18:19:08,532 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:44915. Already tried 5 time(s).
>>
>>
>> ----- Original Message ----
>> From: David Perona <davidperona@yahoo.com>
>> To: hbase-user@hadoop.apache.org
>> Sent: Friday, September 11, 2009 3:07:31 PM
>> Subject: Hbase Client problem
>>
>> It appears that the hbase client is trying to connect to the server  
>> at
>> 127.0.1.1:35059.  This is not the desired behavior, but am not sure  
>> how to
>> correct it.
>>
>> The client (JBOSS) has the following jars in the lib directory:
>> hbase-0.20.0.jar, hadoop-0.20.1-core.jar, and
>> zookeeper-r785019-hbase-1329.jar.  I assume these are the  
>> appropriate ones.
>>
>> I am running Hadoop 0.20.1 and hbase 0.20.0.  Both are running and  
>> have
>> been confirmed through their respective web UIs.  I created a table  
>> in hbase
>> through the shell.  It is a pseudo-distributed deployment. This
>> identical configuration has been successfully run using 0.19 hadoop/ 
>> hbase.
>>
>>
>> hbase-env.sh:  HBASE_MANAGES_ZK=true
>> hbase-site.xml: <property>
>> <name>hbase.zookeeper.quorum</name>
>> <value>192.168.1.68</value>
>> </property>
>> <property>
>> <name>hbase.rootdir</name>
>> <value>hdfs://192.168.1.68:9000/hbase</value>
>> </property>
>>   java client code:
>> HBaseConfiguration config =
>> config.addResource(newHBaseConfiguration();newPath("C://dev/hbase- 
>> site.xml"));HTable
>> table =
>>
>> JBOSS Console:
>> 14:05:13,401 INFO [ZooKeeper] Client
>> environment:zookeeper.version=3.2.0--1, built on 05/15/2009 06:05 GMT
>> 14:05:13,402 INFO [ZooKeeper] Client environment:host.name=
>> d1-laptop.gateway.2wire.net
>> 14:05:13,402 INFO [ZooKeeper] Client  
>> environment:java.version=1.6.0_14
>> 14:05:13,402 INFO [ZooKeeper] Client environment:java.vendor=Sun
>> Microsystems Inc.
>> 14:05:13,402 INFO [ZooKeeper] Client environment:java.home=C: 
>> \Program Files
>> (x86)\Java\jre6
>> 14:05:13,402 INFO [ZooKeeper] Client environment:java.class.path=C: 
>> \JBOSS\
>> jboss-5.1.0.GA\bin\run.jar
>> 14:05:13,403 INFO [ZooKeeper] Client
>> environment:java.io.tmpdir=C:\Users\owner\AppData\Local\Temp\
>> 14:05:13,403 INFO [ZooKeeper] Client environment:java.compiler=<NA>
>> 14:05:13,403 INFO [ZooKeeper] Client environment:os.name=Windows  
>> Vista
>> 14:05:13,403 INFO [ZooKeeper] Client environment:os.arch=x86
>> 14:05:13,403 INFO [ZooKeeper] Client environment:os.version=6.0
>> 14:05:13,403 INFO [ZooKeeper] Client environment:user.name=owner
>> 14:05:13,403 INFO [ZooKeeper] Client environment:user.home=C:\Users 
>> \owner
>> 14:05:13,403 INFO [ZooKeeper] Client environment:user.dir=C:\JBOSS\
>> jboss-5.1.0.GA\bin
>> 14:05:13,405 INFO [ZooKeeper] Initiating client connection, host=
>> 192.168.1.68:2181 sessionTimeout=60000
>> watcher=org.apache.hadoop.hbase.client.HConnectionManager 
>> $ClientZKWatcher@62a5dd
>> 14:05:13,408 INFO [ClientCnxn] zookeeper.disableAutoWatchReset is  
>> false
>> 14:05:14,263 INFO [ClientCnxn] Attempting connection to server /
>> 192.168.1.68:2181
>> 14:05:14,273 INFO [ClientCnxn] Priming connection to
>> java.nio.channels.SocketChannel[connected local=/ 
>> 192.168.1.65:60282remote=/
>> 192.168.1.68:2181]
>> 14:05:14,294 INFO [ClientCnxn] Server connection successful
>> 14:05:16,455 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 0 time(s).
>> 14:05:18,464 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 1 time(s).
>> 14:05:20,457 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 2 time(s).
>> 14:05:22,455 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 3 time(s).
>> 14:05:24,457 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 4 time(s).
>> 14:05:26,458 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 5 time(s).
>> 14:05:28,454 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 6 time(s).
>> 14:05:30,447 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 7 time(s).
>> 14:05:32,444 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 8 time(s).
>> 14:05:34,434 INFO [HBaseClient] Retrying connect to server: /
>> 127.0.1.1:35059. Already tried 9 time(s).
>> 14:05:35,433 INFO [HbaseRPC] Server at /127.0.1.1:35059 not  
>> available yet,
>> Zzzzz...
>>
>> Any help would be appreciated and do not assume that I know what I am
>> doing:)
>>
>> Thanks,
>> DPnewHTable(config, "contact");
>>
>>
>

Mime
View raw message