hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Latham <lat...@davelink.net>
Subject Re: Eclipse crashes when developing Row Filters
Date Wed, 01 Jul 2009 14:05:21 GMT
Hi Ramesh,

I've had the same problem with Eclipse 3.3 and 3.4.  I'm hoping that the
just released 3.5 will have it fixed.  It always seems to happen when
Eclipse tries to auto-complete something from the filter interface, or if
you try to open up the interface.  I've tested it with the prebuilt jars
(0.17, 0.18, and 0.19), and jars I've compiled myself, with or without a
source attachment, and it happens reliably.  The only solution I've found is
to set up an eclipse project with the HBase source and include that during
development of code that uses the filters.  Once I'm done with the filters,
I switch back to using the jars.

I'd love hear if someone else has found a better solution.

Dave

On Wed, Jul 1, 2009 at 5:35 AM, Ramesh.Ramasamy
<ramesh.ramasamy@gmail.com>wrote:

>
> Hi,
>
> I am using Eclipse 3.3, JDK 1.6.0_12 and Hadoop/Hbase 0.19.1.
>
> On coding using some of the filter classes, eclipse hangs, and have no
> other
> option to continue it unless kill/restart the process. Does any body
> figured
> it out the problem and have a fix?
>
> TIA,
> Ramesh
>
>
> --
> View this message in context:
> http://www.nabble.com/help-with-map-reduce-tp22925481p24289040.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message