hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From y_823...@tsmc.com
Subject Re: Region server stopped working or lose connection while running out of memory? (HBASE0.20)
Date Wed, 08 Jul 2009 06:34:39 GMT
Hello,

You have two regionservers and they have different amounts of RAM?
:You're right.

What else is running on these machines?
:Region server must be hadoop datanode?
 My Region server is the hadoop datanode, too.
 No other application run on my pc.

Are your machines swapping -- particularly the 1G regionserver?
:I didn't moniter it.

What kind of machines are they if you don't mind?
:two core intel PC(1.6GHz)

How many regions loaded in your regionserver?
:I don't know. Any command that I can use to find how many regions in my
region server.
 I checked that regionserver webpage :60030/regionserver.jsp, there are 17
region name listing
 on the webpage.

How are you doing your upload?  What kind of application is it?
:I want to put some oracle data to HBase, just by JDBC to fetch a result
set then put it to HBase.

Thank you.

Fleming







                                                                                         
                                                            
                      saint.ack@gmail.c                                                  
                                                            
                      om                       To:      hbase-user@hadoop.apache.org     
                                                            
                      Sent by:                 cc:      (bcc: Y_823910/TSMC)             
                                                            
                      saint.ack@gmail.c        Subject: Re: Region server stopped working
or lose connection while running      out of memory?        
                      om                        (HBASE0.20)                              
                                                            
                                                                                         
                                                            
                                                                                         
                                                            
                      2009/07/08 01:53                                                   
                                                            
                      PM                                                                 
                                                            
                      Please respond to                                                  
                                                            
                      hbase-user                                                         
                                                            
                                                                                         
                                                            
                                                                                         
                                                            




On Tue, Jul 7, 2009 at 10:30 PM, <y_823910@tsmc.com> wrote:

> Hi there,
>
> We have hadoop cluster with only 3PCs. Two are region sever with only 1GB
> and 2GB RAM.



You have two regionservers and they have different amounts of RAM?

By default, HBASE sets its heap at 1G.

What else is running on these machines?

Are your machines swapping -- particularly the 1G regionserver?

What kind of machines are they if you don't mind?


>
> I wonder whether the region server had lost connection or stopped working
> while running out of its memory.



How many regions loaded in your regionserver?


>
> Once I had restarted HBASE, for a while, it worked again.
> If you don't stop putting data to HBase, the full cached region server,
> will have no time to convert
> its cached to HDFS, then it will become untouchable. Is my thinking
> correct?


I'm not sure I follow.  Are you seeing the regionserver overrun?  It can't
keep up with compactions or its not flushing fast enough?

How are you doing your upload?  What kind of application is it?

Thanks,
St.Ack



>
>
> Fleming
>
>
---------------------------------------------------------------------------
>                                                         TSMC PROPERTY
>  This email communication (and any attachments) is proprietary
information
>  for the sole use of its
>  intended recipient. Any unauthorized review, use or distribution by
anyone
>  other than the intended
>  recipient is strictly prohibited.  If you are not the intended
recipient,
>  please notify the sender by
>  replying to this email, and then delete this email and any copies of it
>  immediately. Thank you.
>
>
---------------------------------------------------------------------------
>
>
>
>




 --------------------------------------------------------------------------- 
                                                         TSMC PROPERTY       
 This email communication (and any attachments) is proprietary information   
 for the sole use of its                                                     
 intended recipient. Any unauthorized review, use or distribution by anyone  
 other than the intended                                                     
 recipient is strictly prohibited.  If you are not the intended recipient,   
 please notify the sender by                                                 
 replying to this email, and then delete this email and any copies of it     
 immediately. Thank you.                                                     
 --------------------------------------------------------------------------- 




Mime
View raw message