hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Build 0.2 from svn checkout (NoClassDefFoundError: javax/servlet/jsp/JspFactory)
Date Sat, 25 Jul 2009 17:52:50 GMT
Ah good thing you solved it!

Happy hbase'ing!

J-D

On Sat, Jul 25, 2009 at 1:50 PM, Saptarshi Guha<saptarshi.guha@gmail.com> wrote:
> Latest ant (Apache Ant version 1.7.1 compiled on June 27 2008)
> java version "1.6.0_11" on RHEL 5 (64 bit).
>
> Its a classpath thing. I had set one huge classpath in my bashrc. I
> turned that off and things now build.
>
> Thanks
> Regards
> Saptarshi
>
>
>
> On Sat, Jul 25, 2009 at 10:42 AM, Jean-Daniel Cryans<jdcryans@apache.org> wrote:
>> It generates the web UI pages, kinda cool to have.
>>
>> What's your ant and java version on which OS?
>>
>> J-D
>>
>> On Sat, Jul 25, 2009 at 1:36 PM, Saptarshi Guha<saptarshi.guha@gmail.com> wrote:
>>> I turned of jspc and built (trunk) successfully.
>>> How important is the jspc thing? Could it be my ant is old?
>>>
>>> On Sat, Jul 25, 2009 at 10:34 AM, Amandeep Khurana<amansk@gmail.com> wrote:
>>>> Trunk has a lot of new stuff after alpha and is much more stable.
>>>>
>>>> I just downloaded the trunk and built it without trouble.
>>>>
>>>>
>>>> Amandeep Khurana
>>>> Computer Science Graduate Student
>>>> University of California, Santa Cruz
>>>>
>>>>
>>>> On Sat, Jul 25, 2009 at 10:25 AM, Saptarshi Guha <saptarshi.guha@gmail.com>
>>>> wrote:
>>>>>
>>>>> Hello,
>>>>> I tried building trunk, but get the same error. I wonder what I'm missing.
>>>>>
>>>>> P.S Does trunk fix the delete bug?I.e when I delete a rowkey  (in
>>>>> Hbase-0.20-alpha) I can't add that rowkey again.
>>>>>
>>>>>
>>>>> On Sat, Jul 25, 2009 at 10:15 AM, Saptarshi
>>>>> Guha<saptarshi.guha@gmail.com> wrote:
>>>>> > Hello,
>>>>> > I'm sure this is some trivial error, but I
>>>>> > a) checked out from svn
>>>>> >
>>>>> > svn co http://svn.apache.org/repos/asf/hadoop/hbase/branches/0.2
>>>>> >
>>>>> > b) cd in to 0.2 and ran
>>>>> >
>>>>> > ant
>>>>> >
>>>>> > and got this error
>>>>> > jspc:
>>>>> >
>>>>> > BUILD FAILED
>>>>> > java.lang.NoClassDefFoundError: javax/servlet/jsp/JspFactory
>>>>> >        at org.apache.jasper.JspC.initServletContext(JspC.java:1195)
>>>>> >
>>>>> >
>>>>> > I'm not sure why, since I thought the build is self contained.
>>>>> > Any advice would be appreciated.
>>>>> >
>>>>> > Regards
>>>>> > Saptarshi
>>>>> >
>>>>
>>>>
>>>
>>
>

Mime
View raw message