hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vaibhav Puranik <vpura...@gmail.com>
Subject Re: hbase connection issue
Date Tue, 14 Jul 2009 14:28:12 GMT
Mhuhammad,

Looks like your hbase master didn't start properly. You should check your
master log.

The master log will be in the logs directory. It will have more specific
exception that can help you to find the real problem. If you couldn't solve
it, paste the exception in the log here so that we can help you.

Regards,
Vaibhav

On Tue, Jul 14, 2009 at 6:47 AM, Muhammad Mudassar <mudassark7@gmail.com>wrote:

> Hi,
>
> I am running hbase on single node and my hbase-site seetings are as
> follows:
>
>
> <configuration>
>  <property>
>    <name>hbase.rootdir</name>
>    <value>hdfs://127.0.0.1:9000/hbase</value>
>    <description>The directory shared by region servers.
>    Should be fully-qualified to include the filesystem to use.
>    E.g: hdfs://NAMENODE_SERVER:PORT/HBASE_ROOTDIR
>    </description>
>  </property>
>    <property>
>    <name>hbase.master</name>
>    <value>local</value>
>    <description>The host and port that the HBase master runs at.
>    A value of 'local' runs the master and a regionserver in
>    a single process.
>    </description>
>  </property>
>
> </configuration>
>
>
> After this when I created table in hbase shell it is saying trying to
> connect to the server like:
>
> 09/07/14 19:41:03 INFO ipc.HBaseClass: Retrying connect to server:
> localhost/127.0.0.1:60000. Already tried 0 time(s).
> 09/07/14 19:41:04 INFO ipc.HBaseClass: Retrying connect to server:
> localhost/127.0.0.1:60000. Already tried 1 time(s).
> 09/07/14 19:41:05 INFO ipc.HBaseClass: Retrying connect to server:
> localhost/127.0.0.1:60000. Already tried 2 time(s).
> NativeException: org.apache.hadoop.hbase.MasterNotRunningException:
> localhost:60000
>    from org/apache/hadoop/hbase/client/HConnectionManager.java:239:in
> `getMaster'
>    from org/apache/hadoop/hbase/client/HBaseAdmin.java:70:in `<init>'
>    from sun/reflect/NativeConstructorAccessorImpl.java:-2:in `newInstance0'
>    from sun/reflect/NativeConstructorAccessorImpl.java:39:in `newInstance'
>    from sun/reflect/DelegatingConstructorAccessorImpl.java:27:in
> `newInstance'
>
>
>
> I required help to solve out it!
>
> waiting
>
>
>
> Regards
>
> Muhammad Mudassar
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message