hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitay <nit...@gmail.com>
Subject Re: Error in .20-dev : NotAllMetaRegionsOnlineException
Date Thu, 30 Apr 2009 22:23:44 GMT
No problem, we can do this via email.

Okay, so we know now that your ZooKeeper is up and running and healthy. Your
regionserver being unable to connect to it seems to point at some
configuration issue. What is hbase.master.hostname set to in
conf/hbase-site.xml?

On Thu, Apr 30, 2009 at 3:21 PM, Bradford Stephens <
bradfordstephens@gmail.com> wrote:

> Oh, I misread the wiki.
>
> I can't hop on IRC right now, but I may be able to later. I forgot
> about chat help :) I guess if this question gets too unwieldy, I'll
> jump on.
>
> Running "echo ruok | nc masternode 2181"  returns "imok" :)
>
> running 'stat' from my regionservers returns:
> Zookeeper version: 3.1.0--1, built on 03/05/2009 20:16 GMT
> Clients:
>  /127.0.0.1:42516[1](queued=0,recved=136,sent=136)
>  /192.168.18.47:47238[1](queued=0,recved=0,sent=0)
>
> Latency min/avg/max: 1/4/9
> Received: 136
> Sent: 142
> Outstanding: 0
> Zxid: 0x69f
> Mode: standalone
> Node count: 6
>
> And running a dump:
>
> visibleuser@dttest02:~/hbase/trunk$ echo dump | nc dttest01 2181
> SessionTracker dump:
> Session Sets (3):
> 0 expire at Thu Apr 30 15:17:39 PDT 2009:
> 0 expire at Thu Apr 30 15:17:42 PDT 2009:
> 1 expire at Thu Apr 30 15:17:45 PDT 2009:
>        81338653009313792
>
> ephemeral nodes dump:
> Sessions with Ephemerals (1):
> 0x120f912ef210000:
>        /hbase/master
>
>
> Also, the page on :60100 loads, and gives me a bunch of lines like this:
>
> Trying to contact region server null for region , row '', but failed
> after 10 attempts.
> Exceptions:
> org.apache.hadoop.hbase.client.NoServerForRegionException: Timed out
> trying to locate root region
>
>
>
> On Thu, Apr 30, 2009 at 3:06 PM, Nitay <nitayj@gmail.com> wrote:
> > What are you trying to run? You don't need to run ZooKeeper to use those
> > commands I pointed at.
> >
> > Do you use IRC at all (#hbase)? We can probably troubleshoot this a lot
> > better via that, and then post the results here.
> >
> > On Thu, Apr 30, 2009 at 3:04 PM, Bradford Stephens <
> > bradfordstephens@gmail.com> wrote:
> >
> >> Getting a lot of classpath problems trying to run Zookeeper.... the
> >> one thing I hate the most about Java :)
> >>
> >> BTW, are Hadoop .19.1 and HBase .20-dev compatible?
> >>
> >> On Thu, Apr 30, 2009 at 2:49 PM, Nitay <nitayj@gmail.com> wrote:
> >> > Yes that seems fine. What is hbase.master.hostname set to in
> >> hbase-site.xml?
> >> > That is where ZooKeeper should be runing, i.e. your node with HMaster
> and
> >> > HQuorumPeer. Can you connect to that node at port 2181? Try the ZK
> admin
> >> > commands:
> >> >
> >>
> http://hadoop.apache.org/zookeeper/docs/r3.0.1/zookeeperAdmin.html#sc_zkCommands
> >> >
> >> >
> >> > On Thu, Apr 30, 2009 at 2:40 PM, Bradford Stephens <
> >> > bradfordstephens@gmail.com> wrote:
> >> >
> >> >> Hey,
> >> >>
> >> >> I'm using the defaults that came with the build. I'm running
> >> >> start-hbase.sh ... shouldn't that start Zookeeper? The only jps id
> >> >> that looks like it's related to zookeeper is HQuorumPeer.
> >> >>
> >> >> Here's my conf file:
> >> >> # The number of milliseconds of each tick
> >> >> tickTime=2000
> >> >> # The number of ticks that the initial
> >> >> # synchronization phase can take
> >> >> initLimit=10
> >> >> # The number of ticks that can pass between
> >> >> # sending a request and getting an acknowledgement
> >> >> syncLimit=5
> >> >> # the directory where the snapshot is stored.
> >> >> dataDir=${hbase.tmp.dir}/zookeeper
> >> >> # the port at which the clients will connect
> >> >> clientPort=2181
> >> >>
> >> >> server.0=${hbase.master.hostname}:2888:3888
> >> >>
> >> >>
> >> >> On Thu, Apr 30, 2009 at 2:25 PM, Nitay <nitayj@gmail.com> wrote:
> >> >> > Hi Bradford,
> >> >> >
> >> >> > What's your conf/zoo.cfg look like? Is your ZooKeeper up? Can
you
> >> connect
> >> >> to
> >> >> > it from the RegionServer machine?
> >> >> >
> >> >> > On Thu, Apr 30, 2009 at 11:33 AM, Bradford Stephens <
> >> >> > bradfordstephens@gmail.com> wrote:
> >> >> >
> >> >> >> Oh, I thnk I see the problem. My Regionserver logs contain:
> >> >> >>
> >> >> >> 2009-04-30 11:31:44,320 WARN
> >> >> >> org.apache.hadoop.hbase.regionserver.HRegionServer: Unable
to set
> >> >> >> watcher on ZooKeeper master address. Retrying.
> >> >> >> 2009-04-30 11:31:48,870 WARN
> >> >> >> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: Failed
to set
> >> >> >> watcher on ZNode /hbase/master
> >> >> >>
> >> >> >> What should I do to resolve this?
> >> >> >>
> >> >> >> On Thu, Apr 30, 2009 at 11:17 AM, Bradford Stephens
> >> >> >> <bradfordstephens@gmail.com> wrote:
> >> >> >> > Greetings,
> >> >> >> >
> >> >> >> > On a fresh installation of Hbase .20-dev, I go into the
shell
> and
> >> type
> >> >> >> > "create 'metadata'", just trying to make an empty table.
> >> >> >> > This line pops up:
> >> >> >> > 09/04/30 11:05:29 INFO zookeeper.ZooKeeperWrapper: Quorum
> servers:
> >> >> >> > localhost:2181
> >> >> >> >
> >> >> >> > About 20 seconds later, I get this error: NativeException:
> >> >> >> > org.apache.hadoop.hbase.master.NotAllMetaRegionsOnlineException:
> >> >> >> > org.apache.hadoop.hbase.master.NotAllMetaRegionsOnlineException
> >> >> >> >
> >> >> >> > I've followed all the steps in the wiki to install HBase
and my
> >> Hadoop
> >> >> >> > installation has been running happily for months (.19.1).
Is
> there
> >> >> >> > something that I need to do to start up .20 that is not
covered
> by
> >> the
> >> >> >> > setup wikis?
> >> >> >> >
> >> >> >> > I have the feeling this is also why my web browser spins
when I
> try
> >> to
> >> >> >> > access :60010
> >> >> >> >
> >> >> >> > Running jps on my Namenode/Master node gives me:
> >> >> >> > 5347 SecondaryNameNode
> >> >> >> > 5223 NameNode
> >> >> >> > 7255 HQuorumPeer
> >> >> >> > 5443 JobTracker
> >> >> >> > 7564 HMaster
> >> >> >> > 11034 Jps
> >> >> >> >
> >> >> >> > Running jps on my HBase Regionserver (which has some
other
> things
> >> on
> >> >> >> > it) gives me:
> >> >> >> > 20096 SqlLine
> >> >> >> > 21549 TaskTracker
> >> >> >> > 21480 DataNode
> >> >> >> > 20041 LucidDbServer
> >> >> >> > 7775 Jps
> >> >> >> > 23324 HRegionServer
> >> >> >> >
> >> >> >> >
> >> >> >> > Cheers,
> >> >> >> > Bradford
> >> >> >> >
> >> >> >>
> >> >> >
> >> >>
> >> >
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message