hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: problem in configuring hbase with hdfs
Date Tue, 17 Mar 2009 11:56:05 GMT
Aseem,

It tells you that there is no master to stop so it means that
something went wrong when it got started and shut down by itself. Can
you look in your master log and see if there are any exceptions
thrown?

Thx,

J-D

On Tue, Mar 17, 2009 at 3:32 AM, Puri, Aseem <Aseem.Puri@honeywell.com> wrote:
> Hi
>
>
>
> I am newbie working on Hadoop - HBase. I am using Hadoop-0.18.0 and
> HBase-0.18.1. There is some problem with using HBase master when HBase
> uses HDFS. My Hadoop-site configuration is:
>
>
>
> <configuration>
>
>  <property>
>
>    <name>fs.default.name</name>
>
>    <value>hdfs://localhost:9000</value>
>
>  </property>
>
>  <property>
>
>    <name>mapred.job.tracker</name>
>
>    <value>localhost:9001</value>
>
>  </property>
>
>  <property>
>
>    <name>dfs.replication</name>
>
>    <value>1</value>
>
>  </property>
>
> </configuration>
>
>
>
> And HBase-site configuration is:
>
>
>
> <configuration>
>
>  <property>
>
>    <name>hbase.rootdir</name>
>
>    <value>hdfs://localhost:9000/hbase</value>
>
>    <description>The directory shared by region servers.
>
>    </description>
>
>  </property>
>
>  <property>
>
>    <name>hbase.master</name>
>
>    <value>localhost:60000</value>
>
>    <description>The host and port that the HBase master runs at.
>
>    </description>
>
>  </property>
>
> <property>
>
>    <name>hbase.regionserver</name>
>
>    <value>localhost:60020</value>
>
>    <description>The host and port a HBase region server runs at.
>
>    </description>
>
>  </property>
>
>  </configuration>
>
>
>
> When I try command $ bin/hadoop dfs -ls / I got follwing result:
>
>
>
> $ bin/hadoop dfs -ls /
>
> Found 2 items
>
> drwxr-xr-x   - HadoopAdmin supergroup          0 2009-03-17 12:22 /hbase
>
> drwxr-xr-x   - HadoopAdmin supergroup          0 2009-03-17 12:21 /tmp
>
>
>
> But when I use HBase command list in $ bin/hbase shell I got following
> exception:
>
>
>
> hbase(main):001:0> list
>
> 09/03/17 12:24:24 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 0 time(s).
>
> 09/03/17 12:24:26 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 1 time(s).
>
> 09/03/17 12:24:28 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 2 time(s).
>
> 09/03/17 12:24:29 INFO client.HConnectionManager$TableServers: Attempt 0
> of 5 fa
>
> iled with <java.io.IOException: Call failed on local exception>.
> Retrying after
>
> sleep of 2000
>
> 09/03/17 12:24:33 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 0 time(s).
>
> 09/03/17 12:24:35 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 1 time(s).
>
> 09/03/17 12:24:37 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 2 time(s).
>
> 09/03/17 12:24:38 INFO client.HConnectionManager$TableServers: Attempt 1
> of 5 fa
>
> iled with <java.io.IOException: Call failed on local exception>.
> Retrying after
>
> sleep of 2000
>
> 09/03/17 12:24:42 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 0 time(s).
>
> 09/03/17 12:24:44 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 1 time(s).
>
> 09/03/17 12:24:46 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 2 time(s).
>
> 09/03/17 12:24:48 INFO client.HConnectionManager$TableServers: Attempt 2
> of 5 fa
>
> iled with <java.io.IOException: Call failed on local exception>.
> Retrying after
>
> sleep of 2000
>
> 09/03/17 12:24:52 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 0 time(s).
>
> 09/03/17 12:24:54 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 1 time(s).
>
> 09/03/17 12:24:56 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 2 time(s).
>
> 09/03/17 12:24:57 INFO client.HConnectionManager$TableServers: Attempt 3
> of 5 fa
>
> iled with <java.io.IOException: Call failed on local exception>.
> Retrying after
>
> sleep of 4000
>
> 09/03/17 12:25:03 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 0 time(s).
>
> 09/03/17 12:25:05 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 1 time(s).
>
> 09/03/17 12:25:07 INFO ipc.Client: Retrying connect to server:
> localhost/127.0.0
>
> .1:60000. Already tried 2 time(s).
>
> NativeException: org.apache.hadoop.hbase.MasterNotRunningException:
> localhost:60
>
> 000
>
>        from
> org/apache/hadoop/hbase/client/HConnectionManager.java:221:in `getM
>
> aster'
>
>        from org/apache/hadoop/hbase/client/HBaseAdmin.java:67:in
> `<init>'
>
>        from sun/reflect/NativeConstructorAccessorImpl.java:-2:in
> `newInstance0'
>
>
>
>        from sun/reflect/NativeConstructorAccessorImpl.java:39:in
> `newInstance'
>
>        from sun/reflect/DelegatingConstructorAccessorImpl.java:27:in
> `newInstan
>
> ce'
>
>        from java/lang/reflect/Constructor.java:513:in `newInstance'
>
>        from org/jruby/javasupport/JavaConstructor.java:195:in
> `new_instance'
>
>        from
> org.jruby.javasupport.JavaConstructorInvoker$new_instance_method_0_
>
> 0:-1:in `call'
>
>        from org/jruby/runtime/CallSite.java:261:in `call'
>
>        from org/jruby/evaluator/ASTInterpreter.java:670:in `callNode'
>
>        from org/jruby/evaluator/ASTInterpreter.java:324:in
> `evalInternal'
>
>        from org/jruby/evaluator/ASTInterpreter.java:2173:in `setupArgs'
>
>        from org/jruby/evaluator/ASTInterpreter.java:571:in
> `attrAssignNode'
>
>        from org/jruby/evaluator/ASTInterpreter.java:309:in
> `evalInternal'
>
>        from org/jruby/evaluator/ASTInterpreter.java:620:in `blockNode'
>
>        from org/jruby/evaluator/ASTInterpreter.java:318:in
> `evalInternal'
>
> ... 178 levels...
>
>        from
> ruby/C_3a_/Documents_20_and_20_Settings/HadoopAdmin/hbase/bin/C:\DO
>
> CUME~1\HADOOP~1\hbase\/bin/hirb.rb:-1:in `__file__'
>
>        from
> ruby/C_3a_/Documents_20_and_20_Settings/HadoopAdmin/hbase/bin/C:\DO
>
> CUME~1\HADOOP~1\hbase\/bin/hirb.rb:-1:in `load'
>
>        from org/jruby/Ruby.java:512:in `runScript'
>
>        from org/jruby/Ruby.java:432:in `runNormally'
>
>        from org/jruby/Ruby.java:312:in `runFromMain'
>
>        from org/jruby/Main.java:144:in `run'
>
>        from org/jruby/Main.java:89:in `run'
>
>        from org/jruby/Main.java:80:in `main'
>
>        from file:/C:/Documents and
> Settings/HadoopAdmin/hbase/lib/jruby-complet
>
> e-1.1.2.jar!/builtin/javasupport/proxy/concrete.rb:23:in `initialize'
>
>        from file:/C:/Documents and
> Settings/HadoopAdmin/hbase/lib/jruby-complet
>
> e-1.1.2.jar!/builtin/javasupport/proxy/concrete.rb:6:in `new'
>
>        from file:/C:/Documents and
> Settings/HadoopAdmin/hbase/lib/jruby-complet
>
> e-1.1.2.jar!/builtin/javasupport/proxy/concrete.rb:6:in `new'
>
>        from C:/DOCUME~1/HADOOP~1/hbase/bin/HBase.rb:37:in `initialize'
>
>        from C:\DOCUME~1\HADOOP~1\hbase\/bin/hirb.rb:218:in `new'
>
>        from C:\DOCUME~1\HADOOP~1\hbase\/bin/hirb.rb:218:in `admin'
>
>        from C:\DOCUME~1\HADOOP~1\hbase\/bin/hirb.rb:242:in `list'
>
>        from (hbase):2:in `binding'hbase(main):002:0>
>
>
>
>
>
> Also when I try to stop HBase with the command $ bin/stop-hbase.sh I got
> the message:
>
> no master to stop
>
>
>
> When I change my HBase-site configuration to:
>
>
>
> <configuration>
>
> <property>
>
>    <name>hbase.master</name>
>
>    <value>localhost:60000</value>
>
>    <description>The host and port that the HBase master runs at.
>
>    </description>
>
>  </property>
>
> <property>
>
>    <name>hbase.regionserver</name>
>
>    <value>localhost:60020</value>
>
>    <description>The host and port a HBase region server runs at.
>
>    </description>
>
>  </property>
>
>  </configuration>
>
>
>
> My master starts working as HBase is now using local file system.
>
>
>
> But when I want to use HDFS and change HBase-site configuration then my
> master do not starts. Please tell me how I should configure so my HBase
> master starts working and HBase use HDFS. Hope you people help me in
> this.
>
>
>
> -Aseem
>
>
>
>

Mime
View raw message